aboutsummaryrefslogtreecommitdiff
path: root/utils/domoticz/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-03-04 14:45:01 -0800
committerRosen Penev <rosenp@gmail.com>2021-03-27 21:51:50 -0700
commita31b7320077c340268d31642ded69cc66fbc230c (patch)
tree884808c8657f774a56f82720486b88017f30e6a6 /utils/domoticz/Makefile
parent3ad92293da92b2d5fc3de1ccc214a69f2b081f2e (diff)
treewide: build CMake projects with Ninja
faster to compile. A small selection of packages was tested going from: Executed in 696.30 secs fish external usr time 82.98 mins 395.00 micros 82.98 mins sys time 9.02 mins 0.00 micros 9.02 mins to: Executed in 592.20 secs fish external usr time 84.84 mins 361.00 micros 84.84 mins sys time 8.85 mins 57.00 micros 8.85 mins Tested by running make -j 12 and wiping staging/build_dir/target_x Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/domoticz/Makefile')
-rw-r--r--utils/domoticz/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/utils/domoticz/Makefile b/utils/domoticz/Makefile
index c32da50e0..a7dc4a3a0 100644
--- a/utils/domoticz/Makefile
+++ b/utils/domoticz/Makefile
@@ -19,13 +19,10 @@ PKG_LICENSE:=GPL-3.0
PKG_LICENSE_FILES:=License.txt
PKG_BUILD_DEPENDS:=python3 minizip cereal
-PKG_BUILD_PARALLEL:=1
PKG_USE_MIPS16:=0
-CMAKE_INSTALL:=1
-
include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/cmake.mk
+include ../../devel/ninja/ninja-cmake.mk
define Package/domoticz
SECTION:=utils
@@ -42,7 +39,7 @@ define Package/domoticz
+jsoncpp \
+libcurl \
+python3 \
- +minizip \
+ +minizip @BROKEN \
+lua5.3 \
+libmosquitto \
+libopenssl \