aboutsummaryrefslogtreecommitdiff
path: root/utils/domoticz/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-10-24 15:52:20 -0700
committerRosen Penev <rosenp@gmail.com>2020-11-02 17:41:39 -0800
commit9a56ca92ded3c0a59dd1fafe44bc27c6614360ab (patch)
tree2e9751486d9a27c08ed9e545f067e43b4dc0e0bb /utils/domoticz/Makefile
parent772f4f8d8318a3f62568fbc54b329cff6e4cff7c (diff)
domoticz: fix compilation with python 3.9
Added Fedora patch to fix compilation. Added python3 dependency as it seems it's needed now. Replaced custom boost 1.73 patch with upstream one. Removed CFLAG that was supposed to fix this but didn't do anything. Removed nls.mk. telldus-core was fixed to not require iconv. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/domoticz/Makefile')
-rw-r--r--utils/domoticz/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/utils/domoticz/Makefile b/utils/domoticz/Makefile
index e7bc6e840..c32da50e0 100644
--- a/utils/domoticz/Makefile
+++ b/utils/domoticz/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=domoticz
PKG_VERSION:=2020.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/domoticz/domoticz/archive/$(PKG_VERSION)/$(PKG_SOURCE)
@@ -25,7 +25,6 @@ PKG_USE_MIPS16:=0
CMAKE_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/nls.mk
include $(INCLUDE_DIR)/cmake.mk
define Package/domoticz
@@ -42,6 +41,7 @@ define Package/domoticz
+boost-thread \
+jsoncpp \
+libcurl \
+ +python3 \
+minizip \
+lua5.3 \
+libmosquitto \
@@ -73,8 +73,9 @@ CMAKE_OPTIONS += \
-DUSE_PYTHON=yes \
-DWITH_LIBUSB=no
-TARGET_CFLAGS += -flto -DBOOST_BIND_GLOBAL_PLACEHOLDERS
+TARGET_CFLAGS += -flto
TARGET_CXXFLAGS += -DWITH_GPIO -flto
+TARGET_LDFLAGS += -lpython3.9
define Build/Prepare
$(call Build/Prepare/Default)