aboutsummaryrefslogtreecommitdiff
path: root/utils/domoticz/Makefile
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2017-09-19 22:13:44 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2017-09-20 01:00:41 +0300
commit476dae33c74e83bde8d14e4002df5c5a33a80268 (patch)
treed7a2dfb97cf01910743699d39b32f46d0a54c5aa /utils/domoticz/Makefile
parent3fcbbbf500cdbb1c8ca673ef37c2185aaa0c8711 (diff)
domitcz: fix dzVents scripts
Domoticz 3.8153 introduced support for dzVents. Unfortunately this was broken by the 902_add-scripts-path, which attempts to make Domoticz more FHS-compliant instead of throwing everything under /opt/domoticz. The problem is that dzVents scripts added via the webinterface will be generated on the filesystem. With the 902_add-scripts-path patch, Domoticz tried to write this to "scriptsdir/dzVents/generated_scripts". As the scriptsdir contains scripts that come with upstream, and are not meant to be changed, this defaults to /usr/share/domoticz/scripts, which is not writeable, so Domoticz is unable to write the script to the filesystem. What is worse is that this silently fails. Fix this by moving the generated_scripts dir to "userdatadir/generated_scripts". The userdatadir defaults to /var/lib/domoticz, which is writeable. Additionally, since this patch does more than just adding the scripts path, rename it to something more appropriate. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'utils/domoticz/Makefile')
-rw-r--r--utils/domoticz/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/utils/domoticz/Makefile b/utils/domoticz/Makefile
index 8a330be17..0351ea6d5 100644
--- a/utils/domoticz/Makefile
+++ b/utils/domoticz/Makefile
@@ -11,7 +11,7 @@ PKG_NAME:=domoticz
PKG_VERSION_MAJOR:=3
PKG_VERSION_PATCH:=8153
PKG_VERSION:=$(PKG_VERSION_MAJOR).$(PKG_VERSION_PATCH)
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/domoticz/domoticz/archive/$(PKG_VERSION)/$(PKG_SOURCE)
@@ -72,7 +72,7 @@ define Build/Prepare
buienradar_rain_example.pl \
_domoticz_main* \
download_update.sh \
- dzVents/{.gitignore,documentation,examples} \
+ dzVents/{.gitignore,documentation,examples,generated_scripts} \
dzVents/runtime/{integration-tests,misc/smoothing.xlsx,tests} \
logrotate/ \
lua_parsers/example* \