aboutsummaryrefslogtreecommitdiff
path: root/utils/dockerd/Makefile
diff options
context:
space:
mode:
authorLiang Yang <ggg17226@gmail.com>2022-05-01 01:30:47 +0800
committerRosen Penev <rosenp@gmail.com>2022-04-30 11:54:56 -0700
commit9963312067185d7d47970d2abfb59b6c1a7bfdd5 (patch)
tree8c30b09d22f7de686aa0e95eda01854f63d8306d /utils/dockerd/Makefile
parent170ed0a5d98ceeefc366d4e506909572e25e33e3 (diff)
dockerd: fix compilation with glibc
Signed-off-by: Liang Yang <ggg17226@gmail.com>
Diffstat (limited to 'utils/dockerd/Makefile')
-rw-r--r--utils/dockerd/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/utils/dockerd/Makefile b/utils/dockerd/Makefile
index 71cabb0d1..1300e5a5f 100644
--- a/utils/dockerd/Makefile
+++ b/utils/dockerd/Makefile
@@ -51,6 +51,7 @@ endef
GO_PKG_BUILD_VARS += GO111MODULE=auto
TAR_OPTIONS:=--strip-components 1 $(TAR_OPTIONS)
TAR_CMD=$(HOST_TAR) -C $(1) $(TAR_OPTIONS)
+TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lc -lgcc_eh)
# $(1) = path to dependent package 'Makefile'
# $(2) = relevant dependency '.installer' file