aboutsummaryrefslogtreecommitdiff
path: root/utils/dockerd/Makefile
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2021-02-24 15:37:59 -0300
committerEneas U de Queiroz <cotequeiroz@gmail.com>2021-02-24 19:43:54 -0300
commit8a4bb56478036efccbf6f092647da53e52574518 (patch)
tree90aafeaff5420bb35e536b42f1278d653f5b2df1 /utils/dockerd/Makefile
parent5b2d0609c7ab0698c2fa138d664847195b0b452f (diff)
dockerd: fix build with golang 1.16
Add GO111MODULE=auto to GO_PKG_BUILD_VARS to allow the package to be built in non-module mode. Module-aware mode will be mandatory in the next golang release. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'utils/dockerd/Makefile')
-rw-r--r--utils/dockerd/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/utils/dockerd/Makefile b/utils/dockerd/Makefile
index c34640a85..1390ae098 100644
--- a/utils/dockerd/Makefile
+++ b/utils/dockerd/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dockerd
PKG_VERSION:=20.10.2
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=LICENSE
@@ -46,6 +46,7 @@ define Package/dockerd/description
The Docker CE Engine.
endef
+GO_PKG_BUILD_VARS += GO111MODULE=auto
TAR_OPTIONS:=--strip-components 1 $(TAR_OPTIONS)
TAR_CMD=$(HOST_TAR) -C $(1) $(TAR_OPTIONS)