aboutsummaryrefslogtreecommitdiff
path: root/utils/dockerd/Makefile
diff options
context:
space:
mode:
authorGerard Ryan <G.M0N3Y.2503@gmail.com>2022-04-27 21:11:14 +1000
committerRosen Penev <rosenp@gmail.com>2022-05-14 21:32:36 -0700
commit1f96ec16ecdb98b83244b4c97faf314552948924 (patch)
tree41f97fed7c5b16424dad5831a30c8a36678a2dff /utils/dockerd/Makefile
parent34c77110f1b01e374d9dca0d288933cd6ef9a10e (diff)
dockerd: Add firewall independent dependencies
Signed-off-by: Gerard Ryan <G.M0N3Y.2503@gmail.com>
Diffstat (limited to 'utils/dockerd/Makefile')
-rw-r--r--utils/dockerd/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/utils/dockerd/Makefile b/utils/dockerd/Makefile
index 7b0cc294e..c2cc43db7 100644
--- a/utils/dockerd/Makefile
+++ b/utils/dockerd/Makefile
@@ -34,22 +34,20 @@ define Package/dockerd
TITLE:=Docker Community Edition Daemon
URL:=https://www.docker.com/
DEPENDS:=$(GO_ARCH_DEPENDS) \
- +btrfs-progs \
+ca-certificates \
+containerd \
- +iptables-legacy \
+ +iptables \
+iptables-mod-extra \
- +iptables-mod-nat-extra \
+ +IPV6:ip6tables \
+ +IPV6:kmod-ipt-nat6 \
+KERNEL_SECCOMP:libseccomp \
- +kmod-br-netfilter \
- +kmod-ikconfig \
- +kmod-nf-conntrack-netlink \
+ +kmod-ipt-nat \
+ +kmod-ipt-physdev \
+kmod-nf-ipvs \
- +kmod-nf-nat \
+kmod-veth \
- +libdevmapper \
+libnetwork \
- +tini
+ +tini \
+ +uci-firewall
USERID:=docker:docker
MENU:=1
endef
@@ -146,8 +144,11 @@ define Package/dockerd/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/bundles/binary-daemon/dockerd $(1)/usr/bin/
$(INSTALL_DIR) $(1)/opt/docker/
+
+ ifeq ($(CONFIG_DOCKER_CHECK_CONFIG),y)
$(INSTALL_DIR) $(1)/usr/share/docker/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/contrib/check-config.sh $(1)/usr/share/docker/
+ endif
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/dockerd.init $(1)/etc/init.d/dockerd