aboutsummaryrefslogtreecommitdiff
path: root/utils/dfu-util
diff options
context:
space:
mode:
authorBruno Randolf <br1@einfach.org>2017-03-15 19:32:15 +0000
committerBruno Randolf <br1@einfach.org>2017-03-17 16:52:32 +0000
commit9f2af0d829f7e1210400ca96d4b1cc67068ab446 (patch)
tree3eaed4001a55651d765de9c35f7c1c6e6539ee02 /utils/dfu-util
parent0f73eff96a6480d7791b54843238f5c16de6453d (diff)
dfu-util: Add package
Signed-off-by: Bruno Randolf <br1@einfach.org>
Diffstat (limited to 'utils/dfu-util')
-rw-r--r--utils/dfu-util/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/utils/dfu-util/Makefile b/utils/dfu-util/Makefile
new file mode 100644
index 000000000..813c81d2a
--- /dev/null
+++ b/utils/dfu-util/Makefile
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2017 Bruno Randolf (br1@einfach.org)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=dfu-util
+PKG_VERSION:=0.9
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)/files/
+PKG_MD5SUM:=233bb1e08ef4b405062445d84e28fde6
+PKG_HASH:=36428c6a6cb3088cad5a3592933385253da5f29f2effa61518ee5991ea38f833
+
+PKG_LICENSE:=GPL-2.0+
+PKG_LICENSE_FILES:=COPYING
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/dfu-util
+ SUBMENU:=
+ SECTION:=utils
+ CATEGORY:=Utilities
+ DEPENDS:=+libusb-1.0
+ TITLE:=Device Firmware Upgrade Utilities
+ URL:=http://dfu-util.sourceforge.net/
+ MAINTAINER:=Bruno Randolf <br1@einfach.org>
+endef
+
+define Package/dfu-util/description
+ dfu-util is a host side implementation of the DFU 1.0 and DFU 1.1
+ specifications of the USB forum. DFU is intended to download and
+ upload firmware to/from devices connected over USB.
+endef
+
+define Package/dfu-util/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dfu-util $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,dfu-util))