aboutsummaryrefslogtreecommitdiff
path: root/utils/device-observatory/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-04-10 14:58:07 -0700
committerRosen Penev <rosenp@gmail.com>2019-04-10 16:23:55 -0700
commitb2db7f89542a88dd847108368346dedf2e075e09 (patch)
treeb68882d5e232e3b1288589fbea51008850f8cf07 /utils/device-observatory/Makefile
parent773c19afad0723bc2ba49b36e8172776e2eaf207 (diff)
device-observatory: Add depend on vim to avoid build failure
/bin/sh: 2: xxd: not found /bin/sh: 2: xxd: not found Makefile:24: recipe for target 'src/files.h' failed make[4]: *** [src/files.h] Error 127 Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/device-observatory/Makefile')
-rw-r--r--utils/device-observatory/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/utils/device-observatory/Makefile b/utils/device-observatory/Makefile
index 8a88c3ddb..6970dad08 100644
--- a/utils/device-observatory/Makefile
+++ b/utils/device-observatory/Makefile
@@ -2,14 +2,15 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=device-observatory
PKG_VERSION:=1.2.0
-PKG_RELEASE:=2
-
-PKG_LICENSE:=GPL-3.0+
+PKG_RELEASE:=3
PKG_SOURCE_URL:=https://codeload.github.com/mwarning/device-observatory/tar.gz/v$(PKG_VERSION)?
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_HASH:=83b3f362f154a427abbd3af31b3c2dda9983cdc15f6b833d804727ef0fbdc72e
+PKG_LICENSE:=GPL-3.0+
+PKG_BUILD_DEPENDS:=vim/host
+
include $(INCLUDE_DIR)/package.mk
define Package/device-observatory