aboutsummaryrefslogtreecommitdiff
path: root/utils/ctop
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-08-24 04:59:05 +0800
committerJeffery To <jeffery.to@gmail.com>2020-10-06 16:28:06 +0800
commit9074dbd91770d9913378a3c20e31ea5bde2c2be7 (patch)
treeb9b15368458c0872d2bdfb25fca8b730bf8f0b97 /utils/ctop
parent3dd55b504cb4d7d4ca0251f4ce7b45ec8effeaf8 (diff)
golang: Share build cache across package builds
This also adds a config option GOLANG_BUILD_CACHE_DIR to customize the location of the build cache directory. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'utils/ctop')
-rw-r--r--utils/ctop/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/utils/ctop/Makefile b/utils/ctop/Makefile
index aae82f010..85242dbe5 100644
--- a/utils/ctop/Makefile
+++ b/utils/ctop/Makefile
@@ -35,12 +35,11 @@ endef
MAKE_PATH:=$(GO_PKG_WORK_DIR_NAME)/build/src/$(GO_PKG)
MAKE_VARS += \
GOPATH=$(GO_PKG_BUILD_DIR) \
- GOCACHE=$(GO_PKG_CACHE_DIR) \
- GOTMPDIR=$(GO_PKG_TMP_DIR) \
+ GOCACHE=$(GO_BUILD_CACHE_DIR) \
GOROOT_FINAL=$(GO_TARGET_ROOT) \
CC=$(TARGET_CC) \
CXX=$(TARGET_CXX) \
- $(call GoPackage/Environment)
+ $(GO_PKG_VARS)
MAKE_FLAGS += \
COMMIT=$(PKG_SOURCE_VERSION)