aboutsummaryrefslogtreecommitdiff
path: root/utils/collectd
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2023-08-11 08:23:14 +0200
committerFlorian Eckert <fe@dev.tdt.de>2023-08-11 08:28:25 +0200
commit79201361b01d013a620197691a14c65dabc71627 (patch)
tree68d45a22aed1b7374afa576fa4598ddc7a3d0424 /utils/collectd
parent23f3eb847d152c751005276a0b2388820c806048 (diff)
collectd: fix implicit dependence for collect-mod-disk to libudev
Fix missing dependencies for 'collectd-mod-disk' to 'libudev' if collectd-mod-smart is not enabled. Package collectd-mod-disk is missing dependencies for the following libraries: libudev.so.1 The package 'collect-mod-disk' is now build always with 'libudev' support, independent of the enable/disable build state of 'collectd-mod-smart'. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'utils/collectd')
-rw-r--r--utils/collectd/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/utils/collectd/Makefile b/utils/collectd/Makefile
index 6890694a5..5b7d88a48 100644
--- a/utils/collectd/Makefile
+++ b/utils/collectd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=collectd
PKG_VERSION:=5.12.0
-PKG_RELEASE:=46
+PKG_RELEASE:=47
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://collectd.org/files/ \
@@ -336,13 +336,19 @@ ifneq ($(CONFIG_PACKAGE_collectd-mod-rrdtool),)
CONFIGURE_ARGS+= --with-librrd="$(STAGING_DIR)/usr/lib/rrdtool-1.0"
endif
-# exception: mod-smart needs libatasmart
+# exception: mod-smart needs libatasmart and libudev
ifneq ($(CONFIG_PACKAGE_collectd-mod-smart),)
CONFIGURE_ARGS+= \
--with-libatasmart="$(STAGING_DIR)/usr" \
--with-libudev="$(STAGING_DIR)/usr"
endif
+# exception: mod-disk needs libudev
+ifneq ($(CONFIG_PACKAGE_collectd-mod-disk),)
+ CONFIGURE_ARGS+= \
+ --with-libudev="$(STAGING_DIR)/usr"
+endif
+
define Package/collectd/conffiles
/etc/collectd.conf
/etc/config/collectd
@@ -463,7 +469,7 @@ $(eval $(call BuildPlugin,curl,cURL input,curl,+PACKAGE_collectd-mod-curl:libcur
#$(eval $(call BuildPlugin,dbi,relational database input,dbi,+PACKAGE_collectd-mod-dbi:libdbi))
$(eval $(call BuildPlugin,df,disk space input,df,))
$(eval $(call BuildPlugin,dhcpleases,show dhcpleases,dhcpleases,))
-$(eval $(call BuildPlugin,disk,disk usage/timing input,disk,+PACKAGE_collectd-mod-smart:libudev))
+$(eval $(call BuildPlugin,disk,disk usage/timing input,disk,+PACKAGE_collectd-mod-disk:libudev))
$(eval $(call BuildPlugin,dns,DNS traffic input,dns,+PACKAGE_collectd-mod-dns:libpcap))
$(eval $(call BuildPlugin,email,email output,email,))
$(eval $(call BuildPlugin,entropy,Entropy amount input,entropy,))