aboutsummaryrefslogtreecommitdiff
path: root/utils/collectd
diff options
context:
space:
mode:
authorIlya Lipnitskiy <ilya.lipnitskiy@gmail.com>2021-02-20 16:02:15 -0800
committerIlya Lipnitskiy <ilya.lipnitskiy@gmail.com>2021-02-20 16:02:15 -0800
commit5d8d4fbbcb5c5de9370711c19bb3510210989a98 (patch)
treed0754921833f413b7eb93fb6bb1b1c8a22fb0498 /utils/collectd
parentd651082447b4392399a40ea1ae11d0bce4bfe83a (diff)
treewide: Run refresh on all packages
The crude loop I wrote to come up with this changeset: find -L package/feeds/packages/ -name patches | \ sed 's/patches$/refresh/' | sort | xargs make Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
Diffstat (limited to 'utils/collectd')
-rw-r--r--utils/collectd/patches/920-backport-netlink-reg-noerror.patch4
-rw-r--r--utils/collectd/patches/930-dhcpleases-add-dhcpleases-plugin.patch20
2 files changed, 4 insertions, 20 deletions
diff --git a/utils/collectd/patches/920-backport-netlink-reg-noerror.patch b/utils/collectd/patches/920-backport-netlink-reg-noerror.patch
index 9aef6ab1d..650fb4773 100644
--- a/utils/collectd/patches/920-backport-netlink-reg-noerror.patch
+++ b/utils/collectd/patches/920-backport-netlink-reg-noerror.patch
@@ -24,11 +24,9 @@ Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
src/netlink.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/src/netlink.c b/src/netlink.c
-index 7a5da762c7..fac2fb1eb4 100644
--- a/src/netlink.c
+++ b/src/netlink.c
-@@ -240,7 +240,7 @@ static int check_ignorelist(const char *dev, const char *type,
+@@ -240,7 +240,7 @@ static int check_ignorelist(const char *
for (ir_ignorelist_t *i = ir_ignorelist_head; i != NULL; i = i->next) {
#if HAVE_REGEX_H
if (i->rdevice != NULL) {
diff --git a/utils/collectd/patches/930-dhcpleases-add-dhcpleases-plugin.patch b/utils/collectd/patches/930-dhcpleases-add-dhcpleases-plugin.patch
index 8db3c1d81..03b3902f2 100644
--- a/utils/collectd/patches/930-dhcpleases-add-dhcpleases-plugin.patch
+++ b/utils/collectd/patches/930-dhcpleases-add-dhcpleases-plugin.patch
@@ -18,8 +18,6 @@ Signed-off-by: Nick Hainke <vincent@systemli.org>
5 files changed, 99 insertions(+)
create mode 100644 src/dhcpleases.c
-diff --git a/Makefile.am b/Makefile.am
-index 00947da0..5ee76a00 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -963,6 +963,12 @@ df_la_LDFLAGS = $(PLUGIN_LDFLAGS)
@@ -35,8 +33,6 @@ index 00947da0..5ee76a00 100644
if BUILD_PLUGIN_DISK
pkglib_LTLIBRARIES += disk.la
disk_la_SOURCES = src/disk.c
-diff --git a/README b/README
-index e42e9c24..dd104408 100644
--- a/README
+++ b/README
@@ -106,6 +106,9 @@ Features
@@ -49,11 +45,9 @@ index e42e9c24..dd104408 100644
- dns
DNS traffic: Query types, response codes, opcodes and traffic/octets
transferred.
-diff --git a/configure.ac b/configure.ac
-index bcfb8cf5..6c2b6574 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -7061,6 +7061,7 @@ AC_PLUGIN([curl_xml], [$plugin_curl_xml], [CURL generic xml
+@@ -7063,6 +7063,7 @@ AC_PLUGIN([curl_xml], [$plugi
AC_PLUGIN([dbi], [$with_libdbi], [General database statistics])
AC_PLUGIN([dcpmm], [$with_libpmwapi], [Intel(R) Optane(TM) DC Persistent Memory performance and health statistics])
AC_PLUGIN([df], [$plugin_df], [Filesystem usage statistics])
@@ -61,7 +55,7 @@ index bcfb8cf5..6c2b6574 100644
AC_PLUGIN([disk], [$plugin_disk], [Disk usage statistics])
AC_PLUGIN([dns], [$with_libpcap], [DNS traffic analysis])
AC_PLUGIN([dpdkevents], [$plugin_dpdkevents], [Events from DPDK])
-@@ -7508,6 +7509,7 @@ AC_MSG_RESULT([ curl_xml . . . . . . $enable_curl_xml])
+@@ -7512,6 +7513,7 @@ AC_MSG_RESULT([ curl_xml . . . . . .
AC_MSG_RESULT([ dbi . . . . . . . . . $enable_dbi])
AC_MSG_RESULT([ dcpmm . . . . . . . $enable_dcpmm])
AC_MSG_RESULT([ df . . . . . . . . . $enable_df])
@@ -69,8 +63,6 @@ index bcfb8cf5..6c2b6574 100644
AC_MSG_RESULT([ disk . . . . . . . . $enable_disk])
AC_MSG_RESULT([ dns . . . . . . . . . $enable_dns])
AC_MSG_RESULT([ dpdkevents. . . . . . $enable_dpdkevents])
-diff --git a/src/collectd.conf.in b/src/collectd.conf.in
-index 562a55d9..94659e81 100644
--- a/src/collectd.conf.in
+++ b/src/collectd.conf.in
@@ -119,6 +119,7 @@
@@ -81,7 +73,7 @@ index 562a55d9..94659e81 100644
#@BUILD_PLUGIN_DISK_TRUE@LoadPlugin disk
#@BUILD_PLUGIN_DNS_TRUE@LoadPlugin dns
#@BUILD_PLUGIN_DPDKEVENTS_TRUE@LoadPlugin dpdkevents
-@@ -689,6 +690,10 @@
+@@ -690,6 +691,10 @@
# SelectNumericQueryTypes true
#</Plugin>
@@ -92,9 +84,6 @@ index 562a55d9..94659e81 100644
#<Plugin "dpdkevents">
# <EAL>
# Coremask "0x1"
-diff --git a/src/dhcpleases.c b/src/dhcpleases.c
-new file mode 100644
-index 00000000..f43d62bf
--- /dev/null
+++ b/src/dhcpleases.c
@@ -0,0 +1,83 @@
@@ -181,6 +170,3 @@ index 00000000..f43d62bf
+ config_keys_num);
+ plugin_register_read("dhcpleases", dhcp_leases_read);
+}
---
-2.29.2
-