aboutsummaryrefslogtreecommitdiff
path: root/utils/collectd/Makefile
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2021-01-29 10:40:14 +0100
committerHannu Nyman <hannu.nyman@iki.fi>2021-02-04 09:26:49 +0200
commit93ff4cc743c3aa5581ba4eb1789a784c06c4cc3b (patch)
treee430fb57f4905ce6c698b8441cdc0cb387c5b63d /utils/collectd/Makefile
parent2bbfe1ea4823524c2057c387e0b925bea7731f38 (diff)
collectd: add plugin to compare ipv4,ipv6 stats
Add "ipstatistics"-plugin. This plugin parses "/proc/net/netstat" and "/proc/net/snmp6" to get the overall ipv4 and ipv6 usage. Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'utils/collectd/Makefile')
-rw-r--r--utils/collectd/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/utils/collectd/Makefile b/utils/collectd/Makefile
index c9d6019f9..5d4724601 100644
--- a/utils/collectd/Makefile
+++ b/utils/collectd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=collectd
PKG_VERSION:=5.12.0
-PKG_RELEASE:=6
+PKG_RELEASE:=7
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://collectd.org/files/ \
@@ -153,6 +153,7 @@ COLLECTD_PLUGINS_SELECTED:= \
filecount \
fscache \
interface \
+ ipstatistics \
iptables \
irq \
iwinfo \
@@ -420,6 +421,7 @@ $(eval $(call BuildPlugin,exec,process exec input,exec,))
$(eval $(call BuildPlugin,filecount,file count input,filecount,))
$(eval $(call BuildPlugin,fscache,file-system based caching framework input,fscache,))
$(eval $(call BuildPlugin,interface,network interfaces input,interface,))
+$(eval $(call BuildPlugin,ipstatistics,ipstatistics input,ipstatistics,))
$(eval $(call BuildPlugin,iptables,iptables status input,iptables,+PACKAGE_collectd-mod-iptables:iptables +libip4tc +libip6tc))
$(eval $(call BuildPlugin,irq,interrupt usage input,irq,))
$(eval $(call BuildPlugin,iwinfo,libiwinfo wireless statistics,iwinfo,+PACKAGE_collectd-mod-iwinfo:libiwinfo))