aboutsummaryrefslogtreecommitdiff
path: root/utils/cni
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-10-22 04:02:10 +0100
committerDaniel Golle <dangowrt@users.noreply.github.com>2020-11-07 15:51:49 +0000
commite3a3bc3ed2819b55f617b0d80dd507036999d9cb (patch)
tree858da40be9bb977cdea4415a67bab09864da6d2d /utils/cni
parent62a7bbf7d655e0baa039a3e425c4c8f0e698b31c (diff)
cni: add package
Thanks to @aparcar for help with porting this. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'utils/cni')
-rw-r--r--utils/cni/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/utils/cni/Makefile b/utils/cni/Makefile
new file mode 100644
index 000000000..e428ad628
--- /dev/null
+++ b/utils/cni/Makefile
@@ -0,0 +1,49 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cni
+PKG_VERSION:=0.8.0
+PKG_RELEASE:=1
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/containernetworking/$(PKG_NAME)/archive/v$(PKG_VERSION)
+PKG_HASH:=df8afe3eeae3296ba33ca267041c42f13135c3a067bf2d932761bb02998247a6
+
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>, Paul Spooren <mail@aparcar.org>
+
+PKG_BUILD_DEPENDS:=golang/host
+PKG_BUILD_PARALLEL:=1
+
+GO_PKG:=github.com/containernetworking/cni/
+GO_PKG_BUILD_PKG:=github.com/containernetworking/cni/cnitool
+
+include $(INCLUDE_DIR)/package.mk
+include ../../lang/golang/golang-package.mk
+
+PKG_USE_MIPS16:=0
+
+define Package/cni
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=cni
+ URL:=https://github.com/containernetworking/cni
+ DEPENDS:=$(GO_ARCH_DEPENDS)
+endef
+
+define Package/cni/description
+ CNI (Container Network Interface), a Cloud Native Computing Foundation
+ project, consists of a specification and libraries for writing plugins to
+ configure network interfaces in Linux containers, along with a number of
+ supported plugins. CNI concerns itself only with network connectivity of
+ containers and removing allocated resources when the container is deleted.
+ Because of this focus, CNI has a wide range of support and the specification
+ is simple to implement.
+endef
+
+define Package/cni/install
+ $(call GoPackage/Package/Install/Bin,$(1))
+endef
+
+$(eval $(call GoBinPackage,cni))
+$(eval $(call BuildPackage,cni))