aboutsummaryrefslogtreecommitdiff
path: root/utils/cni
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2021-02-24 15:37:59 -0300
committerEneas U de Queiroz <cotequeiroz@gmail.com>2021-02-24 16:12:58 -0300
commit619270da0e3b81af08cb2924c8484e92b22339de (patch)
treea1e35e0e6758e62da46aa77bbad873639e408cb8 /utils/cni
parentcffae02037e21471e5a0fdc47b171aedbe926e8f (diff)
cni: fix build with golang 1.16
Add GO111MODULE=auto to GO_PKG_BUILD_VARS to allow the package to be built in non-module mode. Module-aware mode will be mandatory in the next golang release. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'utils/cni')
-rw-r--r--utils/cni/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/utils/cni/Makefile b/utils/cni/Makefile
index 895c6d2aa..589d82793 100644
--- a/utils/cni/Makefile
+++ b/utils/cni/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=cni
PKG_VERSION:=0.8.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=LICENSE
@@ -23,6 +23,7 @@ include $(INCLUDE_DIR)/package.mk
include ../../lang/golang/golang-package.mk
PKG_USE_MIPS16:=0
+GO_PKG_BUILD_VARS += GO111MODULE=auto
define Package/cni
SECTION:=utils