aboutsummaryrefslogtreecommitdiff
path: root/utils/ccid/patches
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-10-04 16:04:17 -0700
committerRosen Penev <rosenp@gmail.com>2021-10-08 09:43:07 -0700
commit7a7d1a5d2cbf626119b4bc7598fdbe2d0afa3743 (patch)
treee164e92c44303e45582c856a4be2acb539b77b35 /utils/ccid/patches
parent11fe454c8ae4c207137b6fad2b32f82ef684d94c (diff)
ccid: fix compilation under macOS
Remove a bad uname check. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/ccid/patches')
-rw-r--r--utils/ccid/patches/010-macos.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/utils/ccid/patches/010-macos.patch b/utils/ccid/patches/010-macos.patch
new file mode 100644
index 000000000..0155cde09
--- /dev/null
+++ b/utils/ccid/patches/010-macos.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -79,7 +79,7 @@ AC_CHECK_FUNCS(select strerror strncpy m
+ # Select OS specific versions of source files.
+ AC_SUBST(BUNDLE_HOST)
+ AC_SUBST(DYN_LIB_EXT)
+-BUNDLE_HOST=`uname | sed -e s,/,_,`
++BUNDLE_HOST=Linux
+ DYN_LIB_EXT="so"
+ case "$BUNDLE_HOST" in
+ Darwin)