aboutsummaryrefslogtreecommitdiff
path: root/utils/bluez/patches
diff options
context:
space:
mode:
authorBruno Randolf <br1@einfach.org>2020-04-16 16:10:37 +0100
committerBruno Randolf <br1@einfach.org>2020-04-17 11:27:05 +0100
commitcd26214d0e3e279114deaac8ff766dc69939f854 (patch)
tree287caae7ebc2ad4debd7ba8599e79e0a1aae486a /utils/bluez/patches
parentc11aaead910d5351d0f3fd4e4460ad98336fa0d4 (diff)
bluez: Update to version 5.54
Signed-off-by: Bruno Randolf <br1@einfach.org>
Diffstat (limited to 'utils/bluez/patches')
-rw-r--r--utils/bluez/patches/201-readline.patch20
-rw-r--r--utils/bluez/patches/202-fix-endianness.patch10
-rw-r--r--utils/bluez/patches/205-refresh_adv_manager_for_non-LE_devices.patch8
3 files changed, 21 insertions, 17 deletions
diff --git a/utils/bluez/patches/201-readline.patch b/utils/bluez/patches/201-readline.patch
index 228c0e400..089604fc9 100644
--- a/utils/bluez/patches/201-readline.patch
+++ b/utils/bluez/patches/201-readline.patch
@@ -1,6 +1,8 @@
---- bluez-5.51.orig/Makefile.in
-+++ bluez-5.51/Makefile.in
-@@ -3125,7 +3125,7 @@ unit_tests = $(am__append_54) unit/test-
+Index: bluez-5.54/Makefile.in
+===================================================================
+--- bluez-5.54.orig/Makefile.in
++++ bluez-5.54/Makefile.in
+@@ -3214,7 +3214,7 @@ unit_tests = $(am__append_54) unit/test-
@CLIENT_TRUE@ client/gatt.h client/gatt.c
@CLIENT_TRUE@client_bluetoothctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
@@ -9,16 +11,16 @@
@ZSH_COMPLETIONS_TRUE@zshcompletiondir = $(ZSH_COMPLETIONDIR)
@ZSH_COMPLETIONS_TRUE@dist_zshcompletion_DATA = completion/zsh/_bluetoothctl
-@@ -3358,7 +3358,7 @@ unit_tests = $(am__append_54) unit/test-
+@@ -3452,7 +3452,7 @@ unit_tests = $(am__append_54) unit/test-
@MESH_TRUE@@TOOLS_TRUE@tools_meshctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
@MESH_TRUE@@TOOLS_TRUE@ lib/libbluetooth-internal.la \
-@MESH_TRUE@@TOOLS_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -ljson-c -lreadline
+@MESH_TRUE@@TOOLS_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -ljson-c -lreadline -lncurses
- @DEPRECATED_TRUE@@TOOLS_TRUE@tools_hciattach_SOURCES = tools/hciattach.c tools/hciattach.h \
- @DEPRECATED_TRUE@@TOOLS_TRUE@ tools/hciattach_st.c \
-@@ -3411,7 +3411,7 @@ unit_tests = $(am__append_54) unit/test-
+ @MESH_TRUE@@TOOLS_TRUE@tools_mesh_cfgclient_SOURCES = tools/mesh-cfgclient.c \
+ @MESH_TRUE@@TOOLS_TRUE@ tools/mesh/model.h tools/mesh/config-model.h \
+@@ -3520,7 +3520,7 @@ unit_tests = $(am__append_54) unit/test-
@READLINE_TRUE@ tools/obex-client-tool.c
@READLINE_TRUE@tools_obex_client_tool_LDADD = lib/libbluetooth-internal.la \
@@ -27,7 +29,7 @@
@READLINE_TRUE@tools_obex_server_tool_SOURCES = $(gobex_sources) $(btio_sources) \
@READLINE_TRUE@ tools/obex-server-tool.c
-@@ -3420,15 +3420,15 @@ unit_tests = $(am__append_54) unit/test-
+@@ -3529,15 +3529,15 @@ unit_tests = $(am__append_54) unit/test-
@READLINE_TRUE@tools_bluetooth_player_SOURCES = tools/bluetooth-player.c
@READLINE_TRUE@tools_bluetooth_player_LDADD = gdbus/libgdbus-internal.la \
@READLINE_TRUE@ src/libshared-glib.la \
@@ -46,7 +48,7 @@
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_SOURCES = attrib/gatttool.c attrib/att.c attrib/gatt.c \
@DEPRECATED_TRUE@@READLINE_TRUE@ attrib/gattrib.c btio/btio.c \
-@@ -3437,7 +3437,7 @@ unit_tests = $(am__append_54) unit/test-
+@@ -3546,7 +3546,7 @@ unit_tests = $(am__append_54) unit/test-
@DEPRECATED_TRUE@@READLINE_TRUE@ client/display.h
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_LDADD = lib/libbluetooth-internal.la \
diff --git a/utils/bluez/patches/202-fix-endianness.patch b/utils/bluez/patches/202-fix-endianness.patch
index 8f5e3a67c..34b42cbfa 100644
--- a/utils/bluez/patches/202-fix-endianness.patch
+++ b/utils/bluez/patches/202-fix-endianness.patch
@@ -1,10 +1,12 @@
---- a/src/shared/util.h
-+++ b/src/shared/util.h
+Index: bluez-5.53/src/shared/util.h
+===================================================================
+--- bluez-5.53.orig/src/shared/util.h
++++ bluez-5.53/src/shared/util.h
@@ -26,6 +26,7 @@
#include <alloca.h>
#include <byteswap.h>
#include <string.h>
+#include <endian.h>
- #if __BYTE_ORDER == __LITTLE_ENDIAN
- #define le16_to_cpu(val) (val)
+ #define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
+
diff --git a/utils/bluez/patches/205-refresh_adv_manager_for_non-LE_devices.patch b/utils/bluez/patches/205-refresh_adv_manager_for_non-LE_devices.patch
index 3a67fbec2..f0fc7dcd8 100644
--- a/utils/bluez/patches/205-refresh_adv_manager_for_non-LE_devices.patch
+++ b/utils/bluez/patches/205-refresh_adv_manager_for_non-LE_devices.patch
@@ -32,11 +32,11 @@ This commit prevents the call to btd_adv_manager_refresh for non-LE devices.
src/adapter.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
-Index: bluez-5.51/src/adapter.c
+Index: bluez-5.54/src/adapter.c
===================================================================
---- bluez-5.51.orig/src/adapter.c
-+++ bluez-5.51/src/adapter.c
-@@ -546,7 +546,8 @@ static void settings_changed(struct btd_
+--- bluez-5.54.orig/src/adapter.c
++++ bluez-5.54/src/adapter.c
+@@ -567,7 +567,8 @@ static void settings_changed(struct btd_
g_dbus_emit_property_changed(dbus_conn, adapter->path,
ADAPTER_INTERFACE, "Discoverable");
store_adapter_info(adapter);