aboutsummaryrefslogtreecommitdiff
path: root/utils/bluez/patches
diff options
context:
space:
mode:
authorBruno Randolf <br1@einfach.org>2019-10-11 10:55:28 +0100
committerBruno Randolf <br1@einfach.org>2019-10-16 08:49:23 +0100
commitc1421f56f3ae389824306f7ccc1d3210c6b3f63d (patch)
tree594466bed86d3435c9b7a6ad6eccc2ec63ed1d05 /utils/bluez/patches
parentefe84a67107616016516772e6c758252059288d2 (diff)
bluez: Update to version 5.51
Signed-off-by: Bruno Randolf <br1@einfach.org>
Diffstat (limited to 'utils/bluez/patches')
-rw-r--r--utils/bluez/patches/001-bcm43xx-Add-bcm43xx-3wire-variant.patch8
-rw-r--r--utils/bluez/patches/002-bcm43xx-The-UART-speed-must-be-reset-after-the-firmw.patch10
-rw-r--r--utils/bluez/patches/003-Increase-firmware-load-timeout-to-30s.patch8
-rw-r--r--utils/bluez/patches/004-Move-the-43xx-firmware-into-lib-firmware.patch8
-rw-r--r--utils/bluez/patches/201-readline.patch50
-rw-r--r--utils/bluez/patches/203-obexd_without_systemd.patch18
-rw-r--r--utils/bluez/patches/204-no-printing-subsystem.patch15
-rw-r--r--utils/bluez/patches/205-refresh_adv_manager_for_non-LE_devices.patch8
8 files changed, 63 insertions, 62 deletions
diff --git a/utils/bluez/patches/001-bcm43xx-Add-bcm43xx-3wire-variant.patch b/utils/bluez/patches/001-bcm43xx-Add-bcm43xx-3wire-variant.patch
index 15eb6e1da..070ed5841 100644
--- a/utils/bluez/patches/001-bcm43xx-Add-bcm43xx-3wire-variant.patch
+++ b/utils/bluez/patches/001-bcm43xx-Add-bcm43xx-3wire-variant.patch
@@ -7,9 +7,11 @@ Subject: [PATCH 1/4] bcm43xx: Add bcm43xx-3wire variant
tools/hciattach.c | 3 +++
1 file changed, 3 insertions(+)
---- a/tools/hciattach.c
-+++ b/tools/hciattach.c
-@@ -1090,6 +1090,9 @@ struct uart_t uart[] = {
+Index: bluez-5.51/tools/hciattach.c
+===================================================================
+--- bluez-5.51.orig/tools/hciattach.c
++++ bluez-5.51/tools/hciattach.c
+@@ -1091,6 +1091,9 @@ struct uart_t uart[] = {
{ "bcm43xx", 0x0000, 0x0000, HCI_UART_H4, 115200, 3000000,
FLOW_CTL, DISABLE_PM, NULL, bcm43xx, NULL },
diff --git a/utils/bluez/patches/002-bcm43xx-The-UART-speed-must-be-reset-after-the-firmw.patch b/utils/bluez/patches/002-bcm43xx-The-UART-speed-must-be-reset-after-the-firmw.patch
index a221861d2..0ae7d15cd 100644
--- a/utils/bluez/patches/002-bcm43xx-The-UART-speed-must-be-reset-after-the-firmw.patch
+++ b/utils/bluez/patches/002-bcm43xx-The-UART-speed-must-be-reset-after-the-firmw.patch
@@ -8,9 +8,11 @@ Subject: [PATCH 2/4] bcm43xx: The UART speed must be reset after the firmware
tools/hciattach_bcm43xx.c | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)
---- a/tools/hciattach_bcm43xx.c
-+++ b/tools/hciattach_bcm43xx.c
-@@ -366,11 +366,8 @@ int bcm43xx_init(int fd, int def_speed,
+Index: bluez-5.51/tools/hciattach_bcm43xx.c
+===================================================================
+--- bluez-5.51.orig/tools/hciattach_bcm43xx.c
++++ bluez-5.51/tools/hciattach_bcm43xx.c
+@@ -367,11 +367,8 @@ int bcm43xx_init(int fd, int def_speed,
return -1;
if (bcm43xx_locate_patch(FIRMWARE_DIR, chip_name, fw_path)) {
@@ -23,7 +25,7 @@ Subject: [PATCH 2/4] bcm43xx: The UART speed must be reset after the firmware
if (bcm43xx_load_firmware(fd, fw_path))
return -1;
-@@ -380,6 +377,7 @@ int bcm43xx_init(int fd, int def_speed,
+@@ -381,6 +378,7 @@ int bcm43xx_init(int fd, int def_speed,
return -1;
}
diff --git a/utils/bluez/patches/003-Increase-firmware-load-timeout-to-30s.patch b/utils/bluez/patches/003-Increase-firmware-load-timeout-to-30s.patch
index 74911d3ca..e66ac5e53 100644
--- a/utils/bluez/patches/003-Increase-firmware-load-timeout-to-30s.patch
+++ b/utils/bluez/patches/003-Increase-firmware-load-timeout-to-30s.patch
@@ -7,9 +7,11 @@ Subject: [PATCH 3/4] Increase firmware load timeout to 30s
tools/hciattach.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
---- a/tools/hciattach.c
-+++ b/tools/hciattach.c
-@@ -1239,7 +1239,7 @@ int main(int argc, char *argv[])
+Index: bluez-5.51/tools/hciattach.c
+===================================================================
+--- bluez-5.51.orig/tools/hciattach.c
++++ bluez-5.51/tools/hciattach.c
+@@ -1240,7 +1240,7 @@ int main(int argc, char *argv[])
{
struct uart_t *u = NULL;
int detach, printpid, raw, opt, i, n, ld, err;
diff --git a/utils/bluez/patches/004-Move-the-43xx-firmware-into-lib-firmware.patch b/utils/bluez/patches/004-Move-the-43xx-firmware-into-lib-firmware.patch
index 80b052d5b..b86dc8363 100644
--- a/utils/bluez/patches/004-Move-the-43xx-firmware-into-lib-firmware.patch
+++ b/utils/bluez/patches/004-Move-the-43xx-firmware-into-lib-firmware.patch
@@ -7,9 +7,11 @@ Subject: [PATCH 4/4] Move the 43xx firmware into /lib/firmware
tools/hciattach_bcm43xx.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
---- a/tools/hciattach_bcm43xx.c
-+++ b/tools/hciattach_bcm43xx.c
-@@ -43,7 +43,7 @@
+Index: bluez-5.51/tools/hciattach_bcm43xx.c
+===================================================================
+--- bluez-5.51.orig/tools/hciattach_bcm43xx.c
++++ bluez-5.51/tools/hciattach_bcm43xx.c
+@@ -44,7 +44,7 @@
#include "hciattach.h"
#ifndef FIRMWARE_DIR
diff --git a/utils/bluez/patches/201-readline.patch b/utils/bluez/patches/201-readline.patch
index 01c7e5e9e..228c0e400 100644
--- a/utils/bluez/patches/201-readline.patch
+++ b/utils/bluez/patches/201-readline.patch
@@ -1,43 +1,43 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -2547,7 +2547,7 @@ unit_tests = $(am__append_52) unit/test-
+--- bluez-5.51.orig/Makefile.in
++++ bluez-5.51/Makefile.in
+@@ -3125,7 +3125,7 @@ unit_tests = $(am__append_54) unit/test-
@CLIENT_TRUE@ client/gatt.h client/gatt.c
@CLIENT_TRUE@client_bluetoothctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
--@CLIENT_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -lreadline
-+@CLIENT_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -lreadline -lncurses
+-@CLIENT_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
++@CLIENT_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -lreadline -lncurses
- @MESH_TRUE@mesh_meshctl_SOURCES = mesh/main.c \
- @MESH_TRUE@ mesh/mesh-net.h \
-@@ -2566,7 +2566,7 @@ unit_tests = $(am__append_52) unit/test-
+ @ZSH_COMPLETIONS_TRUE@zshcompletiondir = $(ZSH_COMPLETIONDIR)
+ @ZSH_COMPLETIONS_TRUE@dist_zshcompletion_DATA = completion/zsh/_bluetoothctl
+@@ -3358,7 +3358,7 @@ unit_tests = $(am__append_54) unit/test-
- @MESH_TRUE@mesh_meshctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
- @MESH_TRUE@ lib/libbluetooth-internal.la \
--@MESH_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -ljson-c -lreadline
-+@MESH_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -ljson-c -lreadline -lncurses
+ @MESH_TRUE@@TOOLS_TRUE@tools_meshctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
+ @MESH_TRUE@@TOOLS_TRUE@ lib/libbluetooth-internal.la \
+-@MESH_TRUE@@TOOLS_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -ljson-c -lreadline
++@MESH_TRUE@@TOOLS_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -ljson-c -lreadline -lncurses
- @MONITOR_TRUE@monitor_btmon_SOURCES = monitor/main.c monitor/bt.h \
- @MONITOR_TRUE@ monitor/display.h monitor/display.c \
-@@ -2827,7 +2827,7 @@ unit_tests = $(am__append_52) unit/test-
+ @DEPRECATED_TRUE@@TOOLS_TRUE@tools_hciattach_SOURCES = tools/hciattach.c tools/hciattach.h \
+ @DEPRECATED_TRUE@@TOOLS_TRUE@ tools/hciattach_st.c \
+@@ -3411,7 +3411,7 @@ unit_tests = $(am__append_54) unit/test-
@READLINE_TRUE@ tools/obex-client-tool.c
@READLINE_TRUE@tools_obex_client_tool_LDADD = lib/libbluetooth-internal.la \
--@READLINE_TRUE@ @GLIB_LIBS@ -lreadline
-+@READLINE_TRUE@ @GLIB_LIBS@ -lreadline -lncurses
+-@READLINE_TRUE@ $(GLIB_LIBS) -lreadline
++@READLINE_TRUE@ $(GLIB_LIBS) -lreadline -lncurses
@READLINE_TRUE@tools_obex_server_tool_SOURCES = $(gobex_sources) $(btio_sources) \
@READLINE_TRUE@ tools/obex-server-tool.c
-@@ -2836,15 +2836,15 @@ unit_tests = $(am__append_52) unit/test-
+@@ -3420,15 +3420,15 @@ unit_tests = $(am__append_54) unit/test-
@READLINE_TRUE@tools_bluetooth_player_SOURCES = tools/bluetooth-player.c
@READLINE_TRUE@tools_bluetooth_player_LDADD = gdbus/libgdbus-internal.la \
@READLINE_TRUE@ src/libshared-glib.la \
--@READLINE_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -lreadline
-+@READLINE_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -lreadline -lncurses
+-@READLINE_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
++@READLINE_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -lreadline -lncurses
@READLINE_TRUE@tools_obexctl_SOURCES = tools/obexctl.c
@READLINE_TRUE@tools_obexctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
--@READLINE_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -lreadline
-+@READLINE_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -lreadline -lncurses
+-@READLINE_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
++@READLINE_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -lreadline -lncurses
@READLINE_TRUE@tools_btmgmt_SOURCES = tools/btmgmt.c src/uuid-helper.c client/display.c
@READLINE_TRUE@tools_btmgmt_LDADD = lib/libbluetooth-internal.la src/libshared-mainloop.la \
@@ -46,12 +46,12 @@
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_SOURCES = attrib/gatttool.c attrib/att.c attrib/gatt.c \
@DEPRECATED_TRUE@@READLINE_TRUE@ attrib/gattrib.c btio/btio.c \
-@@ -2853,7 +2853,7 @@ unit_tests = $(am__append_52) unit/test-
+@@ -3437,7 +3437,7 @@ unit_tests = $(am__append_54) unit/test-
@DEPRECATED_TRUE@@READLINE_TRUE@ client/display.h
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_LDADD = lib/libbluetooth-internal.la \
--@DEPRECATED_TRUE@@READLINE_TRUE@ src/libshared-glib.la @GLIB_LIBS@ -lreadline
-+@DEPRECATED_TRUE@@READLINE_TRUE@ src/libshared-glib.la @GLIB_LIBS@ -lreadline -lncurses
+-@DEPRECATED_TRUE@@READLINE_TRUE@ src/libshared-glib.la $(GLIB_LIBS) -lreadline
++@DEPRECATED_TRUE@@READLINE_TRUE@ src/libshared-glib.la $(GLIB_LIBS) -lreadline -lncurses
@CUPS_TRUE@cupsdir = $(libdir)/cups/backend
@CUPS_TRUE@profiles_cups_bluetooth_SOURCES = profiles/cups/main.c \
diff --git a/utils/bluez/patches/203-obexd_without_systemd.patch b/utils/bluez/patches/203-obexd_without_systemd.patch
index 7ed295168..9e3761f92 100644
--- a/utils/bluez/patches/203-obexd_without_systemd.patch
+++ b/utils/bluez/patches/203-obexd_without_systemd.patch
@@ -16,15 +16,17 @@ directly, and to do so it needs the full path of the daemon.
delete mode 100644 obexd/src/org.bluez.obex.service
create mode 100644 obexd/src/org.bluez.obex.service.in
---- a/Makefile.obexd
-+++ b/Makefile.obexd
+Index: bluez-5.51/Makefile.obexd
+===================================================================
+--- bluez-5.51.orig/Makefile.obexd
++++ bluez-5.51/Makefile.obexd
@@ -1,12 +1,12 @@
if SYSTEMD
- systemduserunitdir = @SYSTEMD_USERUNITDIR@
+ systemduserunitdir = $(SYSTEMD_USERUNITDIR)
systemduserunit_DATA = obexd/src/obex.service
+endif
- dbussessionbusdir = @DBUS_SESSIONBUSDIR@
+ dbussessionbusdir = $(DBUS_SESSIONBUSDIR)
dbussessionbus_DATA = obexd/src/org.bluez.obex.service
-endif
@@ -33,15 +35,19 @@ directly, and to do so it needs the full path of the daemon.
if OBEX
---- a/obexd/src/org.bluez.obex.service
+Index: bluez-5.51/obexd/src/org.bluez.obex.service
+===================================================================
+--- bluez-5.51.orig/obexd/src/org.bluez.obex.service
+++ /dev/null
@@ -1,4 +0,0 @@
-[D-BUS Service]
-Name=org.bluez.obex
-Exec=/bin/false
-SystemdService=dbus-org.bluez.obex.service
+Index: bluez-5.51/obexd/src/org.bluez.obex.service.in
+===================================================================
--- /dev/null
-+++ b/obexd/src/org.bluez.obex.service.in
++++ bluez-5.51/obexd/src/org.bluez.obex.service.in
@@ -0,0 +1,4 @@
+[D-BUS Service]
+Name=org.bluez.obex
diff --git a/utils/bluez/patches/204-no-printing-subsystem.patch b/utils/bluez/patches/204-no-printing-subsystem.patch
deleted file mode 100644
index 363bd400e..000000000
--- a/utils/bluez/patches/204-no-printing-subsystem.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/src/bluetooth.conf
-+++ b/src/bluetooth.conf
-@@ -26,10 +26,10 @@
- </policy>
-
- <!-- allow users of lp group (printing subsystem) to
-- communicate with bluetoothd -->
-+ communicate with bluetoothd
- <policy group="lp">
- <allow send_destination="org.bluez"/>
-- </policy>
-+ </policy> -->
-
- <policy context="default">
- <deny send_destination="org.bluez"/>
diff --git a/utils/bluez/patches/205-refresh_adv_manager_for_non-LE_devices.patch b/utils/bluez/patches/205-refresh_adv_manager_for_non-LE_devices.patch
index e9813e684..3a67fbec2 100644
--- a/utils/bluez/patches/205-refresh_adv_manager_for_non-LE_devices.patch
+++ b/utils/bluez/patches/205-refresh_adv_manager_for_non-LE_devices.patch
@@ -32,9 +32,11 @@ This commit prevents the call to btd_adv_manager_refresh for non-LE devices.
src/adapter.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
---- a/src/adapter.c
-+++ b/src/adapter.c
-@@ -540,7 +540,8 @@ static void settings_changed(struct btd_
+Index: bluez-5.51/src/adapter.c
+===================================================================
+--- bluez-5.51.orig/src/adapter.c
++++ bluez-5.51/src/adapter.c
+@@ -546,7 +546,8 @@ static void settings_changed(struct btd_
g_dbus_emit_property_changed(dbus_conn, adapter->path,
ADAPTER_INTERFACE, "Discoverable");
store_adapter_info(adapter);