aboutsummaryrefslogtreecommitdiff
path: root/utils/bluez/patches
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-12-15 16:41:57 -0800
committerRosen Penev <rosenp@gmail.com>2021-12-17 02:55:28 -0800
commit3ee221d0166f3e555e5cc7f07a68113f6d2697bf (patch)
tree28062b55c1efdb92fb649b83499a91c657dcdc5d /utils/bluez/patches
parenta004e872ea17ec0face861dceedd3da0871bcb93 (diff)
bluez: update to 5.62
Refresh patches. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'utils/bluez/patches')
-rw-r--r--utils/bluez/patches/201-readline.patch12
-rw-r--r--utils/bluez/patches/205-refresh_adv_manager_for_non-LE_devices.patch9
2 files changed, 11 insertions, 10 deletions
diff --git a/utils/bluez/patches/201-readline.patch b/utils/bluez/patches/201-readline.patch
index f6dd71662..50bdbeeb2 100644
--- a/utils/bluez/patches/201-readline.patch
+++ b/utils/bluez/patches/201-readline.patch
@@ -1,7 +1,7 @@
--- a/Makefile.in
+++ b/Makefile.in
-@@ -3326,7 +3326,7 @@ unit_tests = $(am__append_52) unit/test-
- @CLIENT_TRUE@ client/gatt.h client/gatt.c
+@@ -3342,7 +3342,7 @@ unit_tests = $(am__append_54) unit/test-
+ @CLIENT_TRUE@ client/admin.c
@CLIENT_TRUE@client_bluetoothctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
-@CLIENT_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
@@ -9,7 +9,7 @@
@ZSH_COMPLETIONS_TRUE@zshcompletiondir = $(ZSH_COMPLETIONDIR)
@ZSH_COMPLETIONS_TRUE@dist_zshcompletion_DATA = completion/zsh/_bluetoothctl
-@@ -3559,7 +3559,7 @@ unit_tests = $(am__append_52) unit/test-
+@@ -3575,7 +3575,7 @@ unit_tests = $(am__append_54) unit/test-
@MESH_TRUE@@TOOLS_TRUE@tools_meshctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
@MESH_TRUE@@TOOLS_TRUE@ lib/libbluetooth-internal.la \
@@ -18,7 +18,7 @@
@MESH_TRUE@@TOOLS_TRUE@tools_mesh_cfgclient_SOURCES = tools/mesh-cfgclient.c \
@MESH_TRUE@@TOOLS_TRUE@ tools/mesh/model.h tools/mesh/config-model.h \
-@@ -3630,7 +3630,7 @@ unit_tests = $(am__append_52) unit/test-
+@@ -3646,7 +3646,7 @@ unit_tests = $(am__append_54) unit/test-
@READLINE_TRUE@ tools/obex-client-tool.c
@READLINE_TRUE@tools_obex_client_tool_LDADD = lib/libbluetooth-internal.la \
@@ -27,7 +27,7 @@
@READLINE_TRUE@tools_obex_server_tool_SOURCES = $(gobex_sources) $(btio_sources) \
@READLINE_TRUE@ tools/obex-server-tool.c
-@@ -3639,15 +3639,15 @@ unit_tests = $(am__append_52) unit/test-
+@@ -3655,15 +3655,15 @@ unit_tests = $(am__append_54) unit/test-
@READLINE_TRUE@tools_bluetooth_player_SOURCES = tools/bluetooth-player.c
@READLINE_TRUE@tools_bluetooth_player_LDADD = gdbus/libgdbus-internal.la \
@READLINE_TRUE@ src/libshared-glib.la \
@@ -46,7 +46,7 @@
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_SOURCES = attrib/gatttool.c attrib/att.c attrib/gatt.c \
@DEPRECATED_TRUE@@READLINE_TRUE@ attrib/gattrib.c btio/btio.c \
-@@ -3656,7 +3656,7 @@ unit_tests = $(am__append_52) unit/test-
+@@ -3672,7 +3672,7 @@ unit_tests = $(am__append_54) unit/test-
@DEPRECATED_TRUE@@READLINE_TRUE@ client/display.h
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_LDADD = lib/libbluetooth-internal.la \
diff --git a/utils/bluez/patches/205-refresh_adv_manager_for_non-LE_devices.patch b/utils/bluez/patches/205-refresh_adv_manager_for_non-LE_devices.patch
index c42739ea8..df1494ff5 100644
--- a/utils/bluez/patches/205-refresh_adv_manager_for_non-LE_devices.patch
+++ b/utils/bluez/patches/205-refresh_adv_manager_for_non-LE_devices.patch
@@ -34,11 +34,12 @@ This commit prevents the call to btd_adv_manager_refresh for non-LE devices.
--- a/src/adapter.c
+++ b/src/adapter.c
-@@ -560,7 +560,8 @@ static void settings_changed(struct btd_
- g_dbus_emit_property_changed(dbus_conn, adapter->path,
- ADAPTER_INTERFACE, "Discoverable");
- store_adapter_info(adapter);
+@@ -606,7 +606,9 @@ static void settings_changed(struct btd_
+ */
+ if (!adapter->discovery_discoverable)
+ store_adapter_info(adapter);
- btd_adv_manager_refresh(adapter->adv_manager);
++
+ if (adapter->supported_settings & MGMT_SETTING_LE)
+ btd_adv_manager_refresh(adapter->adv_manager);
}