aboutsummaryrefslogtreecommitdiff
path: root/utils/beep
diff options
context:
space:
mode:
authorChris Blake <chris@servernetworktech.com>2017-01-16 03:10:38 -0600
committerGitHub <noreply@github.com>2017-01-16 03:10:38 -0600
commit99605fb63069befb79db8b0cc62f9520734b8263 (patch)
tree89ecb41e10dbf056a3e7098ffc4f0e937ee3bdfe /utils/beep
parent2568b67875dc2a5d16453a29595a2150d648cc96 (diff)
Update Makefile
Diffstat (limited to 'utils/beep')
-rw-r--r--utils/beep/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/utils/beep/Makefile b/utils/beep/Makefile
index b59614fb5..f78af91c2 100644
--- a/utils/beep/Makefile
+++ b/utils/beep/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2017 OpenWrt.org
+# Copyright (C) 2017 Chris Blake (chrisrblake93@gmail.com)
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -18,15 +18,15 @@ PKG_SOURCE_PROTO:=git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=$(PKG_REV)
-PKG_LICENSE:=GPL
-PKG_LICENSE_FILES:=
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=COPYING
include $(INCLUDE_DIR)/package.mk
define Package/beep
SECTION:=sound
CATEGORY:=Sound
- DEPENDS:=+kmod-pcspkr
+ DEPENDS:=@(TARGET_x86||TARGET_x86_64) +kmod-pcspkr
TITLE:=Play beep sounds through a PC speaker
URL:=http://johnath.com/beep/README
endef
@@ -35,10 +35,6 @@ define Package/beep/description
This program plays beeps through the PC speaker
endef
-CONFIGURE_ARGS += \
- --enable-static \
- --enable-shared
-
MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS)"