aboutsummaryrefslogtreecommitdiff
path: root/utils/auc/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2017-11-12 23:29:35 +0100
committerDaniel Golle <daniel@makrotopia.org>2017-11-12 23:33:15 +0100
commit95d96a360f0240fcfd7d956f41e354ddd99452c9 (patch)
tree3847287706c382a35ec4e3f1f1d6c240f76e97ee /utils/auc/src/CMakeLists.txt
parent2feef328ed1d28a8b0f1ab94565f9c71aae1e40a (diff)
auc: add new package
The Attended sysUpgrade CLI is a full-featured client for the attended-sysupgrade service which works directly on the target device. It requires libustream-ssl as well as at least the CA certificate needed to contact the sysupgrade server. It has only been tested briefly and is by no means ready for production! Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'utils/auc/src/CMakeLists.txt')
-rw-r--r--utils/auc/src/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/utils/auc/src/CMakeLists.txt b/utils/auc/src/CMakeLists.txt
new file mode 100644
index 000000000..ce291a4e3
--- /dev/null
+++ b/utils/auc/src/CMakeLists.txt
@@ -0,0 +1,12 @@
+cmake_minimum_required(VERSION 2.6)
+
+PROJECT(auc C)
+ADD_DEFINITIONS(-Os -ggdb -Wall --std=gnu99 -Wmissing-declarations)
+
+SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
+
+find_library(json NAMES json-c json)
+
+ADD_EXECUTABLE(auc auc.c)
+TARGET_LINK_LIBRARIES(auc uci ubox ubus uclient blobmsg_json ${json})
+INSTALL(TARGETS auc RUNTIME DESTINATION sbin)