aboutsummaryrefslogtreecommitdiff
path: root/utils/at/Makefile
diff options
context:
space:
mode:
authorPhil Eichinger <phil@zankapfel.net>2015-11-17 17:52:21 +0100
committerPhil Eichinger <phil@zankapfel.net>2015-11-17 17:52:21 +0100
commit212d602c51d7f76ce6a550482e4edf6c8b161f11 (patch)
tree18f400161bcae2968f58f65275197230da52dcd7 /utils/at/Makefile
parentfbec0d5d1196e4c0bdfda8b8d2798776a6fcc0b0 (diff)
at: bring back package
* import from oldpackages * version bump, update hash * add PKG_LICENSE and PKG_LICENSE_FILES * update patches Signed-off-by: Phil Eichinger <phil@zankapfel.net>
Diffstat (limited to 'utils/at/Makefile')
-rw-r--r--utils/at/Makefile59
1 files changed, 59 insertions, 0 deletions
diff --git a/utils/at/Makefile b/utils/at/Makefile
new file mode 100644
index 000000000..0c1473efa
--- /dev/null
+++ b/utils/at/Makefile
@@ -0,0 +1,59 @@
+#
+# Copyright (C) 2008-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=at
+PKG_VERSION:=3.1.16
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
+PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/a/at
+PKG_MD5SUM:=d05da75d9b75d93917ffb16ab48b1e19
+
+PKG_LICENSE:=GPL-2.0+ GPL-3.0+ ISC
+PKG_LICENSE_FILES:=COPYING Copyright
+PKG_MAINTAINER:=Phil Eichinger <phil@zankapfel.net>
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/at
+ SECTION:=utils
+ CATEGORY:=Utilities
+ DEPENDS:=+libelf1
+ TITLE:=Delayed job execution and batch processing
+ URL:=http://packages.debian.org/stable/at
+endef
+
+define Package/at/description
+ At and batch read shell commands from standard input storing them as a job to
+ be scheduled for execution in the future.
+endef
+
+export SENDMAIL=/bin/true
+EXTRA_CFLAGS:=-DNEED_YYWRAP -I$(PKG_BUILD_DIR) \
+ $(TARGET_LDFLAGS)
+
+CONFIGURE_ARGS+=--prefix=/usr \
+ --with-daemon_username=nobody \
+ --with-daemon_groupname=nogroup \
+ --with-jobdir=/var/spool/cron/atjobs \
+ --with-atspool=/var/spool/cron/atspool
+
+CONFIGURE_VARS += \
+ ac_cv_header_security_pam_appl_h=no
+
+define Package/at/install
+ $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/sbin $(1)/etc/init.d/
+ $(INSTALL_BIN) ./files/atd.init $(1)/etc/init.d/atd
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/at $(1)/usr/bin
+ ln -sf at $(1)/usr/bin/atq
+ ln -sf at $(1)/usr/bin/atrm
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/atd $(1)/usr/sbin
+endef
+
+$(eval $(call BuildPackage,at))