aboutsummaryrefslogtreecommitdiff
path: root/utils/ap51-flash/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-04-12 13:46:55 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2017-04-12 18:03:54 -0700
commit31f77baa3aa90b4e9d406a2ba90e8b9afd8f403b (patch)
tree610d529a7a8d783b47d04913728c40aa21db20fd /utils/ap51-flash/Makefile
parent37f6cae8508bfa34d5329dab58dae1470896a0e9 (diff)
ap51-flash: Define IPPORT_TFTP where it is used
Defining IPPORT_TFTP on the pre-processor command line leads to the following error for glibc-based toolchains: mipsel-linux-gnu-gcc -Os -pipe -mno-branch-likely -mips32r2 -mtune=24kc -fno-caller-saves -mips16 -minterlink-mips16 -I/local/users/fainelli/openwrt/trunk/staging_dir/target-mipsel-linux-gnu_glibc/usr/include -I/local/users/fainelli/openwrt/trunk/staging_dir/target-mipsel-linux-gnu_glibc/include -I/opt/toolchains/stbgcc-4.8-1.5/usr/include -I/opt/toolchains/stbgcc-4.8-1.5/include -Wall -Werror -W -g3 -std=gnu99 -Os -fno-strict-aliasing -DLINUX -DREVISION_VERSION=\"2016-10-16\" -DFLASH_FROM_FILE -DNO_LIBPCAP -D_GNU_SOURCE -UIPPORT_TFTP -DIPPORT_TFTP=69 -MD -c flash.c -o flash.o <command-line>:0:13: error: expected identifier before numeric constant Instead, move this where this gets used, in proto.c Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'utils/ap51-flash/Makefile')
-rw-r--r--utils/ap51-flash/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/utils/ap51-flash/Makefile b/utils/ap51-flash/Makefile
index a30fa5d52..af5134ee5 100644
--- a/utils/ap51-flash/Makefile
+++ b/utils/ap51-flash/Makefile
@@ -30,7 +30,7 @@ define Package/ap51-flash
URL:=http://dev.cloudtrax.com/wiki/ap51-flash-station
endef
-TARGET_EXTRA_CFLAGS:=-DFLASH_FROM_FILE -DNO_LIBPCAP -D_GNU_SOURCE -DIPPORT_TFTP=69
+TARGET_EXTRA_CFLAGS:=-DFLASH_FROM_FILE -DNO_LIBPCAP -D_GNU_SOURCE
ifeq ($(CONFIG_BIG_ENDIAN),y)
TARGET_EXTRA_CFLAGS:=$(TARGET_EXTRA_CFLAGS) -DUIP_CONF_BYTE_ORDER=1234
endif