aboutsummaryrefslogtreecommitdiff
path: root/sound
diff options
context:
space:
mode:
authorEspen Jürgensen <espenjurgensen+openwrt@gmail.com>2023-10-28 00:30:17 +0200
committerRosen Penev <rosenp@gmail.com>2023-11-01 15:56:10 -0700
commitdc52f47abbbba839fd89c84f4aacb74abd88757f (patch)
treeaf4256f22c8aa76749e10ffb084ca3d829a7c186 /sound
parentbaa0d5127062929fd26671adb5388f9b30b61a36 (diff)
owntone: update to 28.8
The dependency to libevent-pthread came in version 28.7. The changelog doesn't directly say it, but it is part of the "drop support for libevent < 2.1.4", ref. OwnTone PR #1574: "Support for libevent < 2.1.4 has been removed, and libevent pthreads is now a hard requirement." The configure option --without-libevent_pthreads also no longer exists. Signed-off-by: Espen Jürgensen <espenjurgensen+openwrt@gmail.com>
Diffstat (limited to 'sound')
1 files changed, 4 insertions, 5 deletions
diff --git a/sound/owntone/Makefile b/sound/owntone/Makefile
index 0c4ba66a9..108da781d 100644
--- a/sound/owntone/Makefile
+++ b/sound/owntone/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=owntone
-PKG_VERSION:=28.5
+PKG_VERSION:=28.8
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/owntone/owntone-server/releases/download/$(PKG_VERSION)/
-PKG_HASH:=c9ee0152dc488f782a25a68e72d24c109882bef3dd2914315fe499c8415fd898
+PKG_HASH:=ebaee52ae617f08c41859522ba0a839d1865dcac7d6c0eb9e3fee81caf8fd47c
PKG_FIXUP:=autoreconf
PKG_BUILD_FLAGS:=no-mips16
@@ -32,7 +32,7 @@ CATEGORY:=Sound
TITLE:=iTunes (DAAP) server for Apple Remote and AirPlay
URL:=https://github.com/owntone/owntone-server
DEPENDS:=+libgpg-error +libgcrypt +libgdbm +zlib +libexpat +libunistring \
- +libevent2 +libdaemon +confuse +alsa-lib +libffmpeg-full \
+ +libevent2 +libevent2-pthreads +libdaemon +confuse +alsa-lib +libffmpeg-full \
+mxml +libavahi-client +sqlite3-cli +libplist +libcurl +libjson-c \
+libprotobuf-c +libgnutls +libsodium +libwebsockets +libuuid $(ICONV_DEPENDS)
endef
@@ -54,8 +54,7 @@ CONFIGURE_ARGS += \
--disable-install_conf_file \
--disable-install_user \
--with-alsa \
- --without-pulseaudio \
- --without-libevent_pthreads
+ --without-pulseaudio
TARGET_CFLAGS += $(FPIC)