aboutsummaryrefslogtreecommitdiff
path: root/sound
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2014-07-16 12:31:58 -0400
committerTed Hess <thess@kitschensync.net>2014-07-16 12:31:58 -0400
commitb6b97be93f13f5a4da6f002f9818ae151e406962 (patch)
tree4bd154693237dcc34abb6953243d6aa39d5359ec /sound
parentbccd276c45d6f50d28d412db3be5eadc97a7518d (diff)
Import mpc from oldpackages
Diffstat (limited to 'sound')
-rw-r--r--sound/mpc/Makefile55
-rw-r--r--sound/mpc/files/pls-handler.sh5
2 files changed, 60 insertions, 0 deletions
diff --git a/sound/mpc/Makefile b/sound/mpc/Makefile
new file mode 100644
index 000000000..4bf730847
--- /dev/null
+++ b/sound/mpc/Makefile
@@ -0,0 +1,55 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mpc
+PKG_VERSION:=0.20
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/musicpd
+PKG_MD5SUM:=24c81ad6afe6099e8d7a6826ef4b7105
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/mpc
+ SECTION:=sound
+ CATEGORY:=Sound
+ DEPENDS:=+libmpdclient
+ TITLE:=Music Player Daemon Console Client
+ URL:=http://www.musicpd.org/
+endef
+
+define Package/mpc/description
+ MPD is a music player supporting flac, mp3 and ogg files.
+ It is typically controlled over a network using one of it's many
+ clients including mpc(console), gmpc(gnome), phpmp(php) etc.
+ this is MPC
+endef
+
+define Build/Configure
+$(call Build/Configure/Default, \
+ --disable-iconv \
+)
+endef
+
+define Build/Compile
+$(call Build/Compile/Default,\
+ CFLAGS="$(TARGET_CFLAGS) -std=gnu99" \
+ prefix="/usr" \
+ all \
+)
+endef
+
+define Package/mpc/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mpc $(1)/usr/bin/
+ $(INSTALL_BIN) ./files/pls-handler.sh $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,mpc))
diff --git a/sound/mpc/files/pls-handler.sh b/sound/mpc/files/pls-handler.sh
new file mode 100644
index 000000000..939441783
--- /dev/null
+++ b/sound/mpc/files/pls-handler.sh
@@ -0,0 +1,5 @@
+#!/usr/bin/env sh
+echo parameter: file.pls
+mpc clear
+grep '^File[0-9]*' $1 | sed -e 's/^File[0-9]*=//' | mpc add
+mpc play \ No newline at end of file