aboutsummaryrefslogtreecommitdiff
path: root/sound
diff options
context:
space:
mode:
authorRobert Högberg <robert.hogberg@gmail.com>2022-10-12 10:31:58 +0200
committerRosen Penev <rosenp@gmail.com>2022-10-21 15:04:23 -0700
commitaead0de984cbe17203d56faa057d39845e43ed74 (patch)
tree79879402975b45f5840a74088e1b93b6149bc17e /sound
parent4a16e5eb8c29a5c5584920c29d112e469804a263 (diff)
squeezelite: add SSL support
Signed-off-by: Robert Högberg <robert.hogberg@gmail.com>
Diffstat (limited to 'sound')
-rw-r--r--sound/squeezelite/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/sound/squeezelite/Makefile b/sound/squeezelite/Makefile
index ca6c0c944..cf1d9fb0b 100644
--- a/sound/squeezelite/Makefile
+++ b/sound/squeezelite/Makefile
@@ -36,7 +36,8 @@ define Package/squeezelite-full
$(call Package/squeezelite/default)
TITLE+= (full)
DEPENDS+= +libflac +libvorbis +libmpg123 +libfaad2 \
- +SQUEEZELITE_WMA:libffmpeg-audio-dec
+ +SQUEEZELITE_WMA:libffmpeg-audio-dec \
+ +SQUEEZELITE_SSL:libopenssl
VARIANT:=full
endef
@@ -64,7 +65,13 @@ define Package/squeezelite/config/default
config SQUEEZELITE_DSD
bool "DSD playback over PCM (DoP)"
help
- Include support for DSD over PCM for compatible DAC"
+ Include support for DSD over PCM for compatible DAC
+ default n
+
+ config SQUEEZELITE_SSL
+ bool "SSL/TLS support"
+ help
+ Include SSL/TLS support for use with e.g. https media URLs
default n
endef
@@ -114,6 +121,10 @@ ifeq ($(CONFIG_SQUEEZELITE_RESAMPLE),y)
opts+= -DRESAMPLE
endif
+ifeq ($(CONFIG_SQUEEZELITE_SSL),y)
+ opts+= -DUSE_SSL
+endif
+
ifeq ($(BUILD_VARIANT),full)
opts+= -DLINKALL
endif