aboutsummaryrefslogtreecommitdiff
path: root/sound
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2016-04-17 11:07:57 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2016-04-17 11:07:57 +0200
commit90e88da723619c823e9e7c1287bfa93eb8e41bae (patch)
treeea0b33be00e4a0c5fec8dc7b4e81849d4505379d /sound
parent2db47ee4f18ce4af3dd7222cadcca7dbfe9bc69a (diff)
shairport-sync: update to 2.8.2
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'sound')
3 files changed, 20 insertions, 16 deletions
diff --git a/sound/shairport-sync/Makefile b/sound/shairport-sync/Makefile
index 781b85590..a35f64386 100644
--- a/sound/shairport-sync/Makefile
+++ b/sound/shairport-sync/Makefile
@@ -9,7 +9,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=shairport-sync
-PKG_VERSION:=2.8.1
+PKG_VERSION:=2.8.2
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
diff --git a/sound/shairport-sync/files/shairport-sync.config b/sound/shairport-sync/files/shairport-sync.config
index 0640bde3b..f2256a4e2 100644
--- a/sound/shairport-sync/files/shairport-sync.config
+++ b/sound/shairport-sync/files/shairport-sync.config
@@ -24,11 +24,7 @@ config shairport-sync 'shairport_sync'
option log_verbosity '' # 0/1/2/3
option ignore_volume_control '' # no/yes
option volume_range_db '' # 30 to 150
- # Latencies
- option latencies_default '' # 88200
- option latencies_itunes '' # 99400
- option latencies_airplay '' # 88200
- option latencies_forked_daapd '' # 99400
+ option regtype '' # _raop._tcp
# Metadata
option metadata_enabled '' # no/yes
option metadata_cover_art '' # no/yes
@@ -45,6 +41,9 @@ config shairport-sync 'shairport_sync'
option alsa_mixer_device '' # default
option alsa_latency_offset '' # 0
option alsa_buffer_length '' # 6615
+ option alsa_disable_synchronization '' # no/yes
+ option alsa_period_size '' # number
+ option alsa_buffer_size '' # number
# Pipe
option pipe_name '' # /tmp/shairport-sync-audio
option pipe_latency_offset '' # 0
@@ -52,3 +51,6 @@ config shairport-sync 'shairport_sync'
# Stdout
option stdout_latency_offset '' # 0
option stdout_buffer_length '' # 44100
+ # AO
+ option ao_latency_offset '' # 0
+ option ao_buffer_length '' # 44100
diff --git a/sound/shairport-sync/files/shairport-sync.init b/sound/shairport-sync/files/shairport-sync.init
index ac4b5898f..68c5a6d30 100644
--- a/sound/shairport-sync/files/shairport-sync.init
+++ b/sound/shairport-sync/files/shairport-sync.init
@@ -1,5 +1,5 @@
#!/bin/sh /etc/rc.common
-# Copyright (C) 2015 OpenWrt.org
+# Copyright (C) 2015-2016 OpenWrt.org
START=99
USE_PROCD=1
@@ -59,15 +59,7 @@ start_instance() {
append_num "$cfg" "$conf_file" log_verbosity "log_verbosity"
append_str "$cfg" "$conf_file" ignore_volume_control "ignore_volume_control"
append_num "$cfg" "$conf_file" volume_range_db "volume_range_db"
- echo -e "};\n" >> $conf_file
-
- # Latencies
- echo -e "latencies =" >> $conf_file
- echo -e "{" >> $conf_file
- append_num "$cfg" "$conf_file" latencies_default "default"
- append_num "$cfg" "$conf_file" latencies_itunes "itunes"
- append_num "$cfg" "$conf_file" latencies_airplay "airplay"
- append_num "$cfg" "$conf_file" latencies_forked_daapd "forkedDaapd"
+ append_str "$cfg" "$conf_file" regtype "regtype"
echo -e "};\n" >> $conf_file
# Metadata
@@ -96,6 +88,9 @@ start_instance() {
append_str "$cfg" "$conf_file" alsa_mixer_device "mixer_device"
append_num "$cfg" "$conf_file" alsa_latency_offset "audio_backend_latency_offset"
append_num "$cfg" "$conf_file" alsa_buffer_length "audio_backend_buffer_desired_length"
+ append_str "$cfg" "$conf_file" alsa_disable_synchronization "disable_synchronization"
+ append_num "$cfg" "$conf_file" alsa_period_size "period_size"
+ append_num "$cfg" "$conf_file" alsa_buffer_size "buffer_size"
echo -e "};\n" >> $conf_file
# Pipe audio back end
@@ -112,6 +107,13 @@ start_instance() {
append_num "$cfg" "$conf_file" stdout_latency_offset "audio_backend_latency_offset"
append_num "$cfg" "$conf_file" stdout_buffer_length "audio_backend_buffer_desired_length"
echo -e "};\n" >> $conf_file
+
+ # AO audio back end
+ echo -e "ao =" >> $conf_file
+ echo -e "{" >> $conf_file
+ append_num "$cfg" "$conf_file" ao_latency_offset "audio_backend_latency_offset"
+ append_num "$cfg" "$conf_file" ao_buffer_length "audio_backend_buffer_desired_length"
+ echo -e "};\n" >> $conf_file
fi
procd_open_instance