aboutsummaryrefslogtreecommitdiff
path: root/sound
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-07-10 16:20:21 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2017-07-27 17:13:43 -0700
commit749be47e539e9003a200527363d9a89b757889e7 (patch)
treeb12f31967960a6e7794b227f42a9c98a96c69ed2 /sound
parent113c4e8e91731d841926ae677b422a25349a11b4 (diff)
sox: Explicitly disable support for OpenMP
In case a toolchain happens to be built with OpenMP, sox's configure script would be picking that, but we would not be depending on libgomp and would fail creating the package. Since internal OpenWrt/LEDE toolchains don't enable OpenMP by default, let's just do that here as well. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'sound')
-rw-r--r--sound/sox/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/sound/sox/Makefile b/sound/sox/Makefile
index 34aa32ed1..934b55465 100644
--- a/sound/sox/Makefile
+++ b/sound/sox/Makefile
@@ -52,7 +52,8 @@ CONFIGURE_ARGS += \
--without-png \
--without-sndfile \
--with-lame \
- --with-id3tag
+ --with-id3tag \
+ --disable-openmp
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include