aboutsummaryrefslogtreecommitdiff
path: root/sound/upmpdcli/Makefile
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2016-03-12 01:10:04 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2016-03-12 01:23:28 +0800
commit92b0575e28de89d77300c8163f1a74e3afdeddb4 (patch)
tree38f29d9631cc0ea83e4e1c8631ffec5cbde980cd /sound/upmpdcli/Makefile
parenta0b7f467c915c0f4a67ac696e945c2253019472c (diff)
Drop the redundant -r option to $(CP)
$(CP) was defined as `cp -fpR' since the very begining of OpenWrt build system (2006-06-22). The -R option should be enough and base packages use only $(CP) for the same purposes just fine and BSD manual of cp also discourages the use of `-r' option. So let's just tidy up the usage now. Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'sound/upmpdcli/Makefile')
-rw-r--r--sound/upmpdcli/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/sound/upmpdcli/Makefile b/sound/upmpdcli/Makefile
index 42b98fa73..9c2c1cc95 100644
--- a/sound/upmpdcli/Makefile
+++ b/sound/upmpdcli/Makefile
@@ -54,7 +54,7 @@ endif
ifneq ($(CONFIG_PACKAGE_UPMPDCLI_SC_WEB_INTERFACE),y)
$(RM) -rf $(PKG_INSTALL_DIR)/usr/share/upmpdcli/web
endif
- $(CP) -r $(PKG_INSTALL_DIR)/usr/share/upmpdcli $(1)/usr/share/
+ $(CP) $(PKG_INSTALL_DIR)/usr/share/upmpdcli $(1)/usr/share/
$(INSTALL_DATA) ./files/upmpdcli.png $(1)/usr/share/upmpdcli/
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/upmpdcli.init $(1)/etc/init.d/upmpdcli