aboutsummaryrefslogtreecommitdiff
path: root/sound/squeezelite/Makefile
diff options
context:
space:
mode:
authorRobert Högberg <robert.hogberg@gmail.com>2022-10-11 22:10:53 +0200
committerRosen Penev <rosenp@gmail.com>2022-10-25 18:04:04 -0700
commit15d7c57112fbdcb8ea0c83ee666fd7aba9f73bce (patch)
treef626feadd1a3afdeb405e8c32b496e3aeb487412 /sound/squeezelite/Makefile
parenta3c81940b84b5b0463d751e89f16c04a9fb61800 (diff)
squeezelite: add opus codec support
Signed-off-by: Robert Högberg <robert.hogberg@gmail.com>
Diffstat (limited to 'sound/squeezelite/Makefile')
-rw-r--r--sound/squeezelite/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/sound/squeezelite/Makefile b/sound/squeezelite/Makefile
index cf1d9fb0b..ca4554ec8 100644
--- a/sound/squeezelite/Makefile
+++ b/sound/squeezelite/Makefile
@@ -36,8 +36,9 @@ define Package/squeezelite-full
$(call Package/squeezelite/default)
TITLE+= (full)
DEPENDS+= +libflac +libvorbis +libmpg123 +libfaad2 \
- +SQUEEZELITE_WMA:libffmpeg-audio-dec \
- +SQUEEZELITE_SSL:libopenssl
+ +SQUEEZELITE_OPUS:libopusfile \
+ +SQUEEZELITE_SSL:libopenssl \
+ +SQUEEZELITE_WMA:libffmpeg-audio-dec
VARIANT:=full
endef
@@ -73,6 +74,12 @@ define Package/squeezelite/config/default
help
Include SSL/TLS support for use with e.g. https media URLs
default n
+
+ config SQUEEZELITE_OPUS
+ bool "Opus codec support"
+ help
+ Include Opus codec support
+ default n
endef
define Package/squeezelite-full/config
@@ -91,7 +98,7 @@ define Package/squeezelite/description/default
Squeezelite is a small headless squeezebox emulator for linux using alsa audio output
It is aimed at supporting high quality audio at multiple sample rates including
44.1/48/88.2/96/176.4/192k/352.8/384kHz
- Supported codecs: mp3, flac, ogg, aac, (wma and alac via ffmpeg)
+ Supported codecs: mp3, flac, ogg, aac, (wma and alac via ffmpeg), opus (optional)
Native support for PCM builtin
Optional support of DSD playback via PCM for DoP capable DAC
Optional resampling to match sound device
@@ -125,6 +132,11 @@ ifeq ($(CONFIG_SQUEEZELITE_SSL),y)
opts+= -DUSE_SSL
endif
+ifeq ($(CONFIG_SQUEEZELITE_OPUS),y)
+ opts+= -DOPUS
+ TARGET_CFLAGS+=-I$(STAGING_DIR)/usr/include/opus
+endif
+
ifeq ($(BUILD_VARIANT),full)
opts+= -DLINKALL
endif