aboutsummaryrefslogtreecommitdiff
path: root/sound/sox/patches/001-cross_compile.patch
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2014-07-29 12:31:32 -0400
committerTed Hess <thess@kitschensync.net>2014-07-29 12:31:32 -0400
commitdd7fdad621bf028f477caae55ef17f860bbe3a29 (patch)
tree744c96de009831dc71ca74ad7e6bc3e0120546a5 /sound/sox/patches/001-cross_compile.patch
parent071481e626b2ceef944c85999414cbcfa6331006 (diff)
sox: import from oldpackages, patches to build with newer ffmpeg versions
Signed-off-by: Ted Hess <thess@kitschensync.net>
Diffstat (limited to 'sound/sox/patches/001-cross_compile.patch')
-rw-r--r--sound/sox/patches/001-cross_compile.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/sound/sox/patches/001-cross_compile.patch b/sound/sox/patches/001-cross_compile.patch
new file mode 100644
index 000000000..7996ece92
--- /dev/null
+++ b/sound/sox/patches/001-cross_compile.patch
@@ -0,0 +1,22 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -144,7 +144,7 @@ EXTRA_DIST = monkey.wav optional-fmts.am
+ CMakeLists.txt soxconfig.h.cmake \
+ tests.sh testall.sh tests.bat testall.bat test-comments
+
+-all: sox$(EXEEXT) play rec soxi sox_sample_test$(EXEEXT) example0$(EXEEXT) example1$(EXEEXT) example2$(EXEEXT) example3$(EXEEXT) example4$(EXEEXT) example5$(EXEEXT)
++all: sox$(EXEEXT) play rec
+
+ play rec: sox$(EXEEXT)
+ if test "$(PLAYRECLINKS)" = "yes"; then \
+--- sox-14.4.1/src/Makefile.in
++++ sox-14.4.1/src/Makefile.in
+@@ -2904,7 +2904,7 @@
+ uninstall-libLTLIBRARIES uninstall-pkglibLTLIBRARIES
+
+
+-all: sox$(EXEEXT) play rec soxi sox_sample_test$(EXEEXT) example0$(EXEEXT) example1$(EXEEXT) example2$(EXEEXT) example3$(EXEEXT) example4$(EXEEXT) example5$(EXEEXT)
++all: sox$(EXEEXT) play rec
+
+ play rec: sox$(EXEEXT)
+ if test "$(PLAYRECLINKS)" = "yes"; then \