aboutsummaryrefslogtreecommitdiff
path: root/sound/shine
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-02-09 17:10:09 +0100
committerNicolas Thill <nico@openwrt.org>2015-02-09 17:10:09 +0100
commit39c89a8268b68ebe471d4e0869adab97438879fd (patch)
treeec40b80be0346f6a3b89b302de2cb9ba79c64736 /sound/shine
parenta957258b7874b75c4228d24f449001345159dd80 (diff)
shine: add new package
savonet/shine is a super fast fixed-point MP3 encoder Signed-off-by: Nicolas Thill <nico@openwrt.org>
Diffstat (limited to 'sound/shine')
-rw-r--r--sound/shine/Makefile64
1 files changed, 64 insertions, 0 deletions
diff --git a/sound/shine/Makefile b/sound/shine/Makefile
new file mode 100644
index 000000000..d13cff6ee
--- /dev/null
+++ b/sound/shine/Makefile
@@ -0,0 +1,64 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=shine
+PKG_VERSION:=3.1.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/savonet/shine/releases/download/$(PKG_VERSION)/
+PKG_MD5SUM:=fcad8108335f4b051b303fbdf3fca3fe
+
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=COPYING
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+PKG_USE_MIPS16:=0
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/shine
+ SECTION:=sound
+ CATEGORY:=Sound
+ TITLE:=Super fast fixed-point MP3 encoder
+ URL:=https://github.com/savonet/shine
+endef
+
+define Package/shine/description
+ savonet/shine is a blazing fast mp3 encoding library implemented in fixed-point
+ arithmetic. The library can thus be used to perform super fast mp3 encoding on
+ architectures without a FPU, such as armel, etc.. It is also, however, also
+ super fast on architectures with a FPU!
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/include/shine \
+ $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libshine.{a,so*} \
+ $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/shine.pc \
+ $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/shine/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/shineenc $(1)/usr/bin/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libshine.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,shine))