aboutsummaryrefslogtreecommitdiff
path: root/sound/shairport-sync
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2015-11-04 14:08:51 -0500
committerTed Hess <thess@kitschensync.net>2015-11-04 14:20:29 -0500
commitd1dda2700a47504568c0cf041c10b137e6784051 (patch)
tree23c0dfae00b446e76687cc859a0915db439f2ac6 /sound/shairport-sync
parentf335446e3b4df892387cd4480e1239f9be082759 (diff)
shairport-sync: Add "mini" package (no soxr, no avahi, use polarssl)
Signed-off-by: Ted Hess <thess@kitschensync.net>
Diffstat (limited to 'sound/shairport-sync')
1 files changed, 44 insertions, 21 deletions
diff --git a/sound/shairport-sync/Makefile b/sound/shairport-sync/Makefile
index 4d9805270..8f60ec0e5 100644
--- a/sound/shairport-sync/Makefile
+++ b/sound/shairport-sync/Makefile
@@ -10,14 +10,15 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=shairport-sync
PKG_VERSION:=2.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://github.com/mikebrady/shairport-sync.git
PKG_SOURCE_VERSION:=$(PKG_VERSION)
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>, Mike Brady <mikebrady@eircom.net>
+PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>, \
+ Mike Brady <mikebrady@eircom.net>
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_SOURCE_SUBDIR)
@@ -29,49 +30,42 @@ PKG_FIXUP:=autoreconf
include $(INCLUDE_DIR)/package.mk
-CONFIGURE_ARGS+= \
- --with-alsa \
- --with-avahi \
- --with-soxr \
- --with-metadata
-
-ifeq ($(BUILD_VARIANT),openssl)
- CONFIGURE_ARGS+= --with-ssl=openssl
-endif
-ifeq ($(BUILD_VARIANT),polarssl)
- CONFIGURE_ARGS+= --with-ssl=polarssl
-endif
-
define Package/shairport-sync/default
SECTION:=sound
CATEGORY:=Sound
- TITLE:=iPhone/iTunes/AirPlay/Quicktime Player compatible Audio Player
- DEPENDS:=@AUDIO_SUPPORT +libpthread +libavahi-client +alsa-lib +libconfig +libdaemon +libsoxr +libpopt
+ TITLE:=AirPlay compatible audio player
+ DEPENDS:=@AUDIO_SUPPORT +libpthread +alsa-lib +libconfig +libdaemon +libpopt
URL:=http://github.com/mikebrady/shairport-sync
endef
define Package/shairport-sync-openssl
$(Package/shairport-sync/default)
TITLE+= (openssl)
- DEPENDS+= +PACKAGE_shairport-sync-openssl:libopenssl
+ DEPENDS+= +PACKAGE_shairport-sync-openssl:libopenssl +libavahi-client +libsoxr
VARIANT:=openssl
endef
define Package/shairport-sync-polarssl
$(Package/shairport-sync/default)
TITLE+= (polarssl)
- DEPENDS+= +PACKAGE_shairport-sync-polarssl:libpolarssl
+ DEPENDS+= +PACKAGE_shairport-sync-polarssl:libpolarssl +libavahi-client +libsoxr
VARIANT:=polarssl
DEFAULT_VARIANT:=1
endef
+define Package/shairport-sync-mini
+ $(Package/shairport-sync/default)
+ TITLE+= (minimal)
+ DEPENDS+= +libpolarssl
+ VARIANT:=mini
+endef
+
define Package/shairport-sync/default/description
Shairport Sync plays audio from iTunes and AirPlay sources, including
iOS devices, Quicktime Player and third party sources such as forkedDaapd.
Audio played by a Shairport Sync-powered device stays synchronised with the source
and hence with similar devices playing the same source.
- Thus, for example, synchronised multi-room audio is possible without difficulty.
- (Hence the name Shairport Sync, BTW.)
+
Shairport Sync does not support AirPlay video or photo streaming.
Ensure Kernel Modules > Sound Support > kmod-sound-core is selected.
Also select kmod-usb-audio if you want to use USB-connected sound cards.
@@ -79,11 +73,37 @@ endef
Package/shairport-sync-openssl/description = $(Package/shairport-sync/default/description)
Package/shairport-sync-polarssl/description = $(Package/shairport-sync/default/description)
+define Package/shairport-sync-mini/description
+ $(Package/shairport-sync/default/description)
+
+ Minimal version uses PolarSSL and does not include libsoxr and avahi support.
+endef
+
+CONFIGURE_ARGS+= \
+ --with-alsa \
+ --with-metadata
+
+ifeq ($(BUILD_VARIANT),openssl)
+ CONFIGURE_ARGS+= --with-ssl=openssl
+endif
+
+ifeq ($(BUILD_VARIANT),polarssl)
+ CONFIGURE_ARGS+= --with-ssl=polarssl
+endif
+
+ifeq ($(BUILD_VARIANT),mini)
+ CONFIGURE_ARGS+= --with-ssl=polarssl --with-tinysvcmdns
+else
+ CONFIGURE_ARGS+= --with-avahi --with-soxr
+endif
+
define Package/shairport-sync/default/conffiles
/etc/shairport-sync.conf
endef
+
Package/shairport-sync-openssl/conffiles = $(Package/shairport-sync/default/conffiles)
Package/shairport-sync-polarssl/conffiles = $(Package/shairport-sync/default/conffiles)
+Package/shairport-sync-mini/conffiles = $(Package/shairport-sync/default/conffiles)
define Package/shairport-sync/default/install
$(INSTALL_DIR) $(1)/usr/bin
@@ -95,8 +115,11 @@ define Package/shairport-sync/default/install
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_DATA) ./files/shairport-sync.config $(1)/etc/config/shairport-sync
endef
+
Package/shairport-sync-openssl/install = $(Package/shairport-sync/default/install)
Package/shairport-sync-polarssl/install = $(Package/shairport-sync/default/install)
+Package/shairport-sync-mini/install = $(Package/shairport-sync/default/install)
$(eval $(call BuildPackage,shairport-sync-openssl))
$(eval $(call BuildPackage,shairport-sync-polarssl))
+$(eval $(call BuildPackage,shairport-sync-mini))