aboutsummaryrefslogtreecommitdiff
path: root/sound/shairplay
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2023-11-16 17:56:26 -0800
committerRosen Penev <rosenp@gmail.com>2023-11-16 21:07:43 -0800
commit96b349be98117573a12939ca637f513a411fa120 (patch)
tree3b52d538a1f6428b7d95e0025a73846b1e1670a9 /sound/shairplay
parent303b7b665c5f2aa177d1c4ebbc4346eafd51809b (diff)
shairplay: remove
This package is not only abandoned upstream, it has not worked with iOS versions since at least 2019: https://github.com/juhovh/shairplay/pull/80 Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'sound/shairplay')
-rw-r--r--sound/shairplay/Makefile55
-rw-r--r--sound/shairplay/files/shairplay.config10
-rw-r--r--sound/shairplay/files/shairplay.init51
-rw-r--r--sound/shairplay/patches/001-key_file_dir.patch11
-rw-r--r--sound/shairplay/patches/003-fix_big-endian.patch11
-rw-r--r--sound/shairplay/patches/010-configure-only-check-for-dns_sd.h-in-case-libdl-was-.patch21
6 files changed, 0 insertions, 159 deletions
diff --git a/sound/shairplay/Makefile b/sound/shairplay/Makefile
deleted file mode 100644
index 0b303da3a..000000000
--- a/sound/shairplay/Makefile
+++ /dev/null
@@ -1,55 +0,0 @@
-#
-# Copyright (C) 2014-2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=shairplay
-PKG_SOURCE_DATE:=2018-08-24
-PKG_SOURCE_VERSION:=096b61ad14c90169f438e690d096e3fcf87e504e
-PKG_RELEASE:=2
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_DATE).tar.gz
-PKG_SOURCE_URL:=https://codeload.github.com/juhovh/shairplay/tar.gz/$(PKG_SOURCE_VERSION)?
-PKG_HASH:=7e2b013ffe75ea2f13fb12b1aa38b8e2e8b1899ac292d57f05d7b352a3a181cf
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_SOURCE_VERSION)
-
-PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
-PKG_LICENSE:=MIT
-PKG_LICENSE_FILES:=LICENSE
-
-PKG_FIXUP:=autoreconf
-PKG_BUILD_PARALLEL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/shairplay
- SECTION:=sound
- CATEGORY:=Sound
- DEPENDS:=+libao +libavahi-compat-libdnssd +libltdl +libpthread
- TITLE:=Shairplay
-endef
-
-define Package/shairplay/description
- Free portable AirPlay server implementation similar to ShairPort.
-endef
-
-define Package/shairplay/conffiles
-/etc/config/shairplay
-endef
-
-define Package/shairplay/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/shairplay $(1)/usr/bin/
- $(INSTALL_DIR) $(1)/usr/share/shairplay
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/airport.key $(1)/usr/share/shairplay/
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) files/shairplay.init $(1)/etc/init.d/shairplay
- $(INSTALL_DIR) $(1)/etc/config
- $(INSTALL_CONF) files/shairplay.config $(1)/etc/config/shairplay
-endef
-
-$(eval $(call BuildPackage,shairplay))
diff --git a/sound/shairplay/files/shairplay.config b/sound/shairplay/files/shairplay.config
deleted file mode 100644
index 6e1f93937..000000000
--- a/sound/shairplay/files/shairplay.config
+++ /dev/null
@@ -1,10 +0,0 @@
-config shairplay main
- option disabled '1'
- option respawn '1'
- option apname 'AirPlay'
- option port '5000'
- option password ''
- option hwaddr ''
- option ao_driver 'oss'
- option ao_devicename ''
- option ao_deviceid ''
diff --git a/sound/shairplay/files/shairplay.init b/sound/shairplay/files/shairplay.init
deleted file mode 100644
index 093a16805..000000000
--- a/sound/shairplay/files/shairplay.init
+++ /dev/null
@@ -1,51 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2014 OpenWrt.org
-
-START=90
-USE_PROCD=1
-
-append_arg() {
- local cfg="$1"
- local var="$2"
- local opt="$3"
- local def="$4"
- local val
-
- config_get val "$cfg" "$var"
- [ -n "$val" -o -n "$def" ] && procd_append_param command $opt="${val:-$def}"
-}
-
-start_instance() {
- local cfg="$1"
- local aux
-
- config_get_bool aux "$cfg" 'disabled' '0'
- [ "$aux" = 1 ] && return 1
-
- procd_open_instance
-
- procd_set_param command /usr/bin/shairplay
-
- append_arg "$cfg" apname "--apname" "AirPlay"
- append_arg "$cfg" port "--server_port"
- append_arg "$cfg" password "--password"
- append_arg "$cfg" hwaddr "--hwaddr"
-
- append_arg "$cfg" ao_driver "--ao_driver"
- append_arg "$cfg" ao_devicename "--ao_devicename"
- append_arg "$cfg" ao_deviceid "--ao_deviceid"
-
- config_get_bool aux "$cfg" 'respawn' '0'
- [ "$aux" = 1 ] && procd_set_param respawn
-
- procd_close_instance
-}
-
-service_triggers() {
- procd_add_reload_trigger "shairplay"
-}
-
-start_service() {
- config_load shairplay
- config_foreach start_instance shairplay
-}
diff --git a/sound/shairplay/patches/001-key_file_dir.patch b/sound/shairplay/patches/001-key_file_dir.patch
deleted file mode 100644
index af9bd8448..000000000
--- a/sound/shairplay/patches/001-key_file_dir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/shairplay.c
-+++ b/src/shairplay.c
-@@ -350,7 +350,7 @@ main(int argc, char *argv[])
- raop_cbs.audio_destroy = audio_destroy;
- raop_cbs.audio_set_volume = audio_set_volume;
-
-- raop = raop_init_from_keyfile(10, &raop_cbs, "airport.key", NULL);
-+ raop = raop_init_from_keyfile(10, &raop_cbs, "/usr/share/shairplay/airport.key", NULL);
- if (raop == NULL) {
- fprintf(stderr, "Could not initialize the RAOP service\n");
- fprintf(stderr, "Please make sure the airport.key file is in the current directory.\n");
diff --git a/sound/shairplay/patches/003-fix_big-endian.patch b/sound/shairplay/patches/003-fix_big-endian.patch
deleted file mode 100644
index 4db204eb7..000000000
--- a/sound/shairplay/patches/003-fix_big-endian.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/lib/alac/alac.c
-+++ b/src/lib/alac/alac.c
-@@ -29,7 +29,7 @@
- *
- */
-
--static const int host_bigendian = 0;
-+#define host_bigendian (htonl(42) == 42)
-
- #include <stdio.h>
- #include <stdlib.h>
diff --git a/sound/shairplay/patches/010-configure-only-check-for-dns_sd.h-in-case-libdl-was-.patch b/sound/shairplay/patches/010-configure-only-check-for-dns_sd.h-in-case-libdl-was-.patch
deleted file mode 100644
index 84db6b8c6..000000000
--- a/sound/shairplay/patches/010-configure-only-check-for-dns_sd.h-in-case-libdl-was-.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From 031c3d802e51bbc233b1044f812402a66bfcf237 Mon Sep 17 00:00:00 2001
-From: Memphiz <memphis@machzwo.de>
-Date: Fri, 21 Dec 2018 20:39:11 +0100
-Subject: [PATCH] [configure] - only check for dns_sd.h in case libdl was not
- found
-
----
- configure.ac | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -19,7 +19,7 @@ LT_LIB_DLLOAD
-
- # Checks for header files.
- AC_HEADER_STDC
--if test yes = "$libltdl_cv_func_dlopen" || test yes = "$libltdl_cv_lib_dl_dlopen"
-+if test no = "$libltdl_cv_func_dlopen" && test no = "$libltdl_cv_lib_dl_dlopen"
- then
- AC_CHECK_HEADERS([dns_sd.h], [],
- [AC_MSG_ERROR([Could not find dns_sd.h header, please install libavahi-compat-libdnssd-dev or equivalent.])])