aboutsummaryrefslogtreecommitdiff
path: root/sound/pulseaudio/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-09-02 21:45:45 -0700
committertripolar <tripolar@users.noreply.github.com>2019-09-06 19:57:58 +0200
commit8410380ae9f69838ca2dbacb2df782311f87fce6 (patch)
treed7482d3c5ce83778be03b08e4d2f1d8cc53da2d9 /sound/pulseaudio/Makefile
parent5935670ba14ed575799e4df4e4227826e3fef682 (diff)
pulseaudio: Add glib2/host dependency
This was implicit with glib2 but got removed with 170ef79393aabc7cfbe3cd4625dc01f0fcc25221 Fixed license tag to newer SPDX. Removed PKG_BUILD_DIR as that is now default with upstream's e545fac8d968864a965edb9e50c6f90940b0a6c9 Minor reorganization for consistency. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'sound/pulseaudio/Makefile')
-rw-r--r--sound/pulseaudio/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/sound/pulseaudio/Makefile b/sound/pulseaudio/Makefile
index 9601c704e..fc6c9aade 100644
--- a/sound/pulseaudio/Makefile
+++ b/sound/pulseaudio/Makefile
@@ -9,24 +9,21 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pulseaudio
PKG_VERSION:=12.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://freedesktop.org/software/pulseaudio/releases/
PKG_HASH:=809668ffc296043779c984f53461c2b3987a45b7a25eb2f0a1d11d9f23ba4055
-PKG_LICENSE:=LGPL-2.1+
-PKG_LICENSE_FILES:=GPL LICENSE
-PKG_BUILD_PARALLEL:=1
-PKG_BUILD_DEPENDS:=intltool/host
+PKG_LICENSE:=LGPL-2.1-or-later
+PKG_LICENSE_FILES:=GPL LICENSE
PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+PKG_BUILD_DEPENDS:=intltool/host glib2/host
PKG_USE_MIPS16:=0
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
-
-PKG_INSTALL = 1
-
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk