aboutsummaryrefslogtreecommitdiff
path: root/sound/pulseaudio/Makefile
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2016-03-25 17:45:18 -0400
committerTed Hess <thess@kitschensync.net>2016-03-25 17:48:41 -0400
commit6c0d7a1db73573190f9f4ccb25a1340bb6c9a742 (patch)
treef51b0d6da79734174e2370e42272280a2ba94049 /sound/pulseaudio/Makefile
parent99a49889a167bab40c7d647e826a65fb954f72d0 (diff)
pulseaudio: build without soxr, install configs with all read permissions
Signed-off-by: Ted Hess <thess@kitschensync.net>
Diffstat (limited to 'sound/pulseaudio/Makefile')
-rw-r--r--sound/pulseaudio/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/sound/pulseaudio/Makefile b/sound/pulseaudio/Makefile
index 909d7902c..b84449f07 100644
--- a/sound/pulseaudio/Makefile
+++ b/sound/pulseaudio/Makefile
@@ -99,7 +99,8 @@ CONFIGURE_ARGS += \
--disable-udev \
--without-fftw \
--disable-avahi \
- --disable-dbus
+ --disable-dbus \
+ --without-soxr
CONFIGURE_VARS += \
PKG_CONFIG_LIBDIR="$(STAGING_DIR)/usr/lib/pkgconfig"
@@ -144,7 +145,7 @@ define Package/pulseaudio-daemon/install
./files/pulseaudio.init \
$(1)/etc/init.d/pulseaudio
- $(INSTALL_CONF) \
+ $(INSTALL_DATA) \
$(PKG_INSTALL_DIR)/etc/pulse/* \
$(1)/etc/pulse
@@ -164,7 +165,6 @@ define Package/pulseaudio-daemon/install
$(PKG_INSTALL_DIR)/usr/lib/pulse-$(PKG_VERSION)/modules/module*.so \
$(1)/usr/lib/pulse-$(PKG_VERSION)/modules/
- chmod -R 0644 $(1)/etc/pulse/*
endef
define Package/pulseaudio-tools/install
@@ -181,11 +181,11 @@ define Package/pulseaudio-profiles/install
$(1)/usr/share/pulseaudio/alsa-mixer/paths \
$(1)/usr/share/pulseaudio/alsa-mixer/profile-sets
- $(INSTALL_CONF) \
+ $(INSTALL_DATA) \
$(PKG_INSTALL_DIR)/usr/share/pulseaudio/alsa-mixer/paths/* \
$(1)/usr/share/pulseaudio/alsa-mixer/paths
- $(INSTALL_CONF) \
+ $(INSTALL_DATA) \
$(PKG_INSTALL_DIR)/usr/share/pulseaudio/alsa-mixer/profile-sets/* \
$(1)/usr/share/pulseaudio/alsa-mixer/profile-sets
endef