aboutsummaryrefslogtreecommitdiff
path: root/sound/pulseaudio/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-07-30 16:41:16 -0700
committerRosen Penev <rosenp@gmail.com>2020-07-30 23:58:42 -0700
commit67f8f57d06ab8776ad58371bb2a3be5cc995fcd6 (patch)
tree44a85db821ee7b90622c7016465a015393bc3032 /sound/pulseaudio/Makefile
parentaad1458876e8a20739a7f2d21eec36ce2998681c (diff)
pulseaudio: fix compilation with ICONV_FULL
Reordered check to check external iconv first. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'sound/pulseaudio/Makefile')
-rw-r--r--sound/pulseaudio/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/sound/pulseaudio/Makefile b/sound/pulseaudio/Makefile
index 6a7ec3c52..a79f2a00c 100644
--- a/sound/pulseaudio/Makefile
+++ b/sound/pulseaudio/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pulseaudio
PKG_VERSION:=13.0
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://freedesktop.org/software/pulseaudio/releases
@@ -143,7 +143,7 @@ MESON_ARGS += \
-Ddbus=disabled
endif
-TARGET_LDFLAGS += -Wl,--gc-sections -liconv
+TARGET_LDFLAGS += -Wl,--gc-sections $(if $(INTL_FULL),-lintl)
define Build/Prepare
$(call Build/Prepare/Default)