aboutsummaryrefslogtreecommitdiff
path: root/sound/pulseaudio/Makefile
diff options
context:
space:
mode:
authorJohnny Vogels <35307256+jmv2009@users.noreply.github.com>2018-02-06 19:42:09 +0100
committerGitHub <noreply@github.com>2018-02-06 19:42:09 +0100
commit256905edad5d2e1e89c29741eb018e44e518021c (patch)
tree72915fad8655882da553824db3c52139638332f3 /sound/pulseaudio/Makefile
parentfaa8ce76907390256476079c2dfa49bbd4f83cf3 (diff)
Pulseaudio: variant avahi/bluez
Signed-off-by: Johnny Vogels <35307256+jmv2009@users.noreply.github.com>
Diffstat (limited to 'sound/pulseaudio/Makefile')
-rw-r--r--sound/pulseaudio/Makefile86
1 files changed, 82 insertions, 4 deletions
diff --git a/sound/pulseaudio/Makefile b/sound/pulseaudio/Makefile
index 4b3487faa..9c4da8fc3 100644
--- a/sound/pulseaudio/Makefile
+++ b/sound/pulseaudio/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pulseaudio
PKG_VERSION:=11.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://freedesktop.org/software/pulseaudio/releases/
@@ -22,6 +22,8 @@ PKG_BUILD_DEPENDS:=intltool/host
PKG_FIXUP:=autoreconf
PKG_USE_MIPS16:=0
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
+
PKG_INSTALL = 1
include $(INCLUDE_DIR)/package.mk
@@ -41,6 +43,15 @@ endef
define Package/pulseaudio-daemon
$(call Package/pulseaudio/Default)
+ VARIANT:=noavahi
+endef
+
+define Package/pulseaudio-daemon-avahi
+ $(call Package/pulseaudio/Default)
+ DEPENDS+=+dbus +libavahi-client +sbc
+# DEPENDS+=+avahi-daemon
+ TITLE+= (avahi/bluez)
+ VARIANT:=avahi
endef
define Package/pulseaudio/Default/description
@@ -51,6 +62,11 @@ define Package/pulseaudio-daemon/description
$(call Package/pulseaudio/Default/description)
endef
+define Package/pulseaudio-daemon-avahi/description
+ $(call Package/pulseaudio/Default/description)
+ This package enables avahi,bluez and is compiled against dbus, sbc, and avahi.
+endef
+
define Package/pulseaudio-daemon/conffiles
/etc/pulse/client.conf
/etc/pulse/daemon.conf
@@ -58,12 +74,20 @@ define Package/pulseaudio-daemon/conffiles
/etc/pulse/system.pa
endef
+define Package/pulseaudio-daemon-avahi/conffiles
+/etc/pulse/client.conf
+/etc/pulse/daemon.conf
+/etc/pulse/default.pa
+/etc/pulse/system.pa
+endef
+
define Package/pulseaudio-tools
SECTION:=sound
CATEGORY:=Sound
DEPENDS:=+libsndfile +pulseaudio
TITLE:=Tools for Pulseaudio
URL:=http://www.pulseaudio.org
+ VARIANT:=noavahi
endef
define Package/pulseaudio-profiles
@@ -94,13 +118,23 @@ CONFIGURE_ARGS += \
--disable-jack \
--disable-asyncns \
--disable-lirc \
- --disable-bluez \
--disable-udev \
--without-fftw \
- --disable-avahi \
- --disable-dbus \
--without-soxr \
--without-speex
+# --disable-bluez
+
+ifeq ($(BUILD_VARIANT),avahi)
+CONFIGURE_ARGS += \
+ --enable-avahi \
+ --enable-dbus
+endif
+
+ifeq ($(BUILD_VARIANT),noavahi)
+CONFIGURE_ARGS += \
+ --disable-avahi \
+ --disable-dbus
+endif
CONFIGURE_VARS += \
PKG_CONFIG_LIBDIR="$(STAGING_DIR)/usr/lib/pkgconfig"
@@ -167,6 +201,49 @@ define Package/pulseaudio-daemon/install
endef
+define Package/pulseaudio-daemon-avahi/install
+ $(INSTALL_DIR) \
+ $(1)/etc/pulse \
+ $(1)/etc/init.d \
+ $(1)/usr/bin \
+ $(1)/usr/lib \
+ $(1)/usr/lib/pulseaudio \
+ $(1)/usr/lib/pulse-$(PKG_VERSION)/modules \
+ $(1)/etc/dbus-1/system.d
+
+ $(INSTALL_BIN) \
+ $(PKG_INSTALL_DIR)/usr/bin/pulseaudio \
+ $(1)/usr/bin/pulseaudio
+
+ $(INSTALL_BIN) \
+ ./files/pulseaudio.init \
+ $(1)/etc/init.d/pulseaudio
+
+ $(INSTALL_DATA) \
+ $(PKG_INSTALL_DIR)/etc/pulse/* \
+ $(1)/etc/pulse
+
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/*.so* \
+ $(1)/usr/lib/
+
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/pulseaudio/* \
+ $(1)/usr/lib/pulseaudio/
+
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/pulse-$(PKG_VERSION)/modules/lib*.so \
+ $(1)/usr/lib/
+
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/pulse-$(PKG_VERSION)/modules/module*.so \
+ $(1)/usr/lib/pulse-$(PKG_VERSION)/modules/
+
+ $(INSTALL_DATA) \
+ $(PKG_INSTALL_DIR)/etc/dbus-1/system.d/pulseaudio-system.conf \
+ $(1)/etc/dbus-1/system.d/pulseaudio-system.conf
+endef
+
define Package/pulseaudio-tools/install
$(INSTALL_DIR) \
$(1)/usr/bin
@@ -191,5 +268,6 @@ define Package/pulseaudio-profiles/install
endef
$(eval $(call BuildPackage,pulseaudio-daemon))
+$(eval $(call BuildPackage,pulseaudio-daemon-avahi))
$(eval $(call BuildPackage,pulseaudio-tools))
$(eval $(call BuildPackage,pulseaudio-profiles))