aboutsummaryrefslogtreecommitdiff
path: root/sound/mpd/patches/010-iconv.patch
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-07-20 17:50:38 -0700
committerRosen Penev <rosenp@gmail.com>2020-07-20 19:56:51 -0700
commitdfdc430a4a41d83d5f44d14c0cad4b684eba475a (patch)
treeacefe9dcfc59e38e7d5bd958aea2c1bd37541021 /sound/mpd/patches/010-iconv.patch
parent5d42bf7550140b9b1e6ecb394798ef8254d45eda (diff)
mpd: update to 0.21.25
pulseaudio-daemon depends on alsa-lib, which depends on @AUDIO_SUPPORT. Enables -full on platforms lacking AUDIO_SUPPORT. Simplified LDFLAGS slighly. Removed pointless ICU dependency. I managed to patch meson.build to fix iconv compilation. The original error was that without the header, it was prefixing the iconv check with __buildin_ , which does not work with uClibc-ng. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'sound/mpd/patches/010-iconv.patch')
-rw-r--r--sound/mpd/patches/010-iconv.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/sound/mpd/patches/010-iconv.patch b/sound/mpd/patches/010-iconv.patch
new file mode 100644
index 000000000..730b27108
--- /dev/null
+++ b/sound/mpd/patches/010-iconv.patch
@@ -0,0 +1,11 @@
+--- a/src/lib/icu/meson.build
++++ b/src/lib/icu/meson.build
+@@ -18,7 +18,7 @@ if icu_dep.found()
+ 'Init.cxx',
+ ]
+ elif not get_option('iconv').disabled()
+- have_iconv = compiler.has_function('iconv')
++ have_iconv = compiler.has_function('iconv', prefix : '#include <iconv.h>')
+ conf.set('HAVE_ICONV', have_iconv)
+ if not have_iconv and get_option('iconv').enabled()
+ error('iconv() not available')