aboutsummaryrefslogtreecommitdiff
path: root/sound/mpc/Makefile
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2019-09-20 17:18:34 +0200
committerAndre Heider <a.heider@gmail.com>2019-11-05 10:28:30 +0100
commit0469c0715b10e8b32fe41e3b3b7248379ffe6046 (patch)
treee15a57eecaad558c3bf57f2f14f710bb3a8d7e23 /sound/mpc/Makefile
parent8a7d276618ebd0d065dd6c0eca523d11d8a7a088 (diff)
mpc: update to v0.32 and build with meson
Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'sound/mpc/Makefile')
-rw-r--r--sound/mpc/Makefile20
1 files changed, 7 insertions, 13 deletions
diff --git a/sound/mpc/Makefile b/sound/mpc/Makefile
index ff50bbce4..3424e3d13 100644
--- a/sound/mpc/Makefile
+++ b/sound/mpc/Makefile
@@ -6,21 +6,24 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mpc
-PKG_VERSION:=0.30
-PKG_RELEASE:=3
+PKG_VERSION:=0.32
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.musicpd.org/download/mpc/0
-PKG_HASH:=65fc5b0a8430efe9acbe6e261127960682764b20ab994676371bdc797d867fce
+PKG_HASH:=7961d95b7ce019996beab281cf957e905667c989c53fffd13ade5e62fea331c7
PKG_LICENSE:=GPL-2.0-or-later
PKG_LICENSE_FILES:=COPYING
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
-PKG_FIXUP:=autoreconf
+PKG_BUILD_DEPENDS:=meson/host
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
+include ../../devel/meson/meson.mk
+
+MESON_ARGS+=-Diconv=disabled -Ddocumentation=disabled
define Package/mpc
SECTION:=sound
@@ -37,15 +40,6 @@ define Package/mpc/description
this is MPC
endef
-CONFIGURE_ARGS+= --disable-iconv
-
-# Newer sources require meson/ninja to build so...
-# Use our hacked-up version of the mpc v0.28 autotools.
-define Build/Prepare
- $(call Build/Prepare/Default)
- $(CP) ./autotools-files/* $(PKG_BUILD_DIR)/
-endef
-
define Package/mpc/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mpc $(1)/usr/bin/