aboutsummaryrefslogtreecommitdiff
path: root/sound/lame
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2016-11-17 11:49:27 -0500
committerTed Hess <thess@kitschensync.net>2016-11-17 11:49:27 -0500
commit125066a1d7a8bfbb3a742163ab2cef46e666a858 (patch)
tree4b3adf9679ce3c4ad3ebb3f4487793db1b45a5a1 /sound/lame
parent7dfde961433ac65c7d480dfedec1475d3e878fcc (diff)
lame: Fix i386 SSE builds, disable NASM (really)
Signed-off-by: Ted Hess <thess@kitschensync.net>
Diffstat (limited to 'sound/lame')
-rw-r--r--sound/lame/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/sound/lame/Makefile b/sound/lame/Makefile
index e7057e5e9..41a90f7d5 100644
--- a/sound/lame/Makefile
+++ b/sound/lame/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007-2014 OpenWrt.org
+# Copyright (C) 2007-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lame
PKG_VERSION:=3.99.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/lame
@@ -53,12 +53,11 @@ define Package/lame-lib/description
lame mp3 encoder libs
endef
-define Build/Configure
- $(call Build/Configure/Default, \
- --disable-nasm \
- )
-endef
+CONFIG_VARS+=NASM=no
+ifeq ($(ARCH),i386)
+TARGET_CFLAGS+=-msse
+endif
define Package/lame/install
$(INSTALL_DIR) $(1)/usr/bin