aboutsummaryrefslogtreecommitdiff
path: root/sound/forked-daapd
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-03-29 21:26:24 -0700
committerRosen Penev <rosenp@gmail.com>2020-03-29 21:28:37 -0700
commite3bee35404463fea9c7d3620df72d0d90a6485e8 (patch)
treed7b763cf49d432fd254c0cac46e1711b27ce1ff9 /sound/forked-daapd
parent067c93b028b123184737f09751f73e46a5d44824 (diff)
forked-daapd: fix compilation with newer musl
Needed for errno definition. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'sound/forked-daapd')
-rw-r--r--sound/forked-daapd/Makefile2
-rw-r--r--sound/forked-daapd/patches/010-errno.patch10
2 files changed, 11 insertions, 1 deletions
diff --git a/sound/forked-daapd/Makefile b/sound/forked-daapd/Makefile
index 9dc7aad30..8e911f910 100644
--- a/sound/forked-daapd/Makefile
+++ b/sound/forked-daapd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=forked-daapd
PKG_VERSION:=27.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/ejurgensen/$(PKG_NAME)/releases/download/$(PKG_VERSION)/
diff --git a/sound/forked-daapd/patches/010-errno.patch b/sound/forked-daapd/patches/010-errno.patch
new file mode 100644
index 000000000..b7fee52d0
--- /dev/null
+++ b/sound/forked-daapd/patches/010-errno.patch
@@ -0,0 +1,10 @@
+--- a/src/websocket.c
++++ b/src/websocket.c
+@@ -25,6 +25,7 @@
+ #ifdef HAVE_PTHREAD_NP_H
+ # include <pthread_np.h>
+ #endif
++#include <errno.h>
+ #include <stdbool.h>
+ #include <stdio.h>
+ #include <string.h>