aboutsummaryrefslogtreecommitdiff
path: root/sound/forked-daapd
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-09-17 16:15:30 -0700
committerRosen Penev <rosenp@gmail.com>2019-09-17 17:44:22 -0700
commit398f6a754c07f752afced0eecf83726f1d92f8d9 (patch)
tree84b177145f757d3463c1962b82efe055edbdd9f0 /sound/forked-daapd
parentc56ad06395037628ddccf2620b5ce7a590e86ee8 (diff)
forked-daapd: Fix compilation with newer alsa-libs
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'sound/forked-daapd')
-rw-r--r--sound/forked-daapd/Makefile2
-rw-r--r--sound/forked-daapd/patches/010-alsa.patch36
2 files changed, 37 insertions, 1 deletions
diff --git a/sound/forked-daapd/Makefile b/sound/forked-daapd/Makefile
index c2cb4e941..76d21a59a 100644
--- a/sound/forked-daapd/Makefile
+++ b/sound/forked-daapd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=forked-daapd
PKG_VERSION:=26.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/ejurgensen/$(PKG_NAME)/releases/download/$(PKG_VERSION)/
diff --git a/sound/forked-daapd/patches/010-alsa.patch b/sound/forked-daapd/patches/010-alsa.patch
new file mode 100644
index 000000000..a4256ab68
--- /dev/null
+++ b/sound/forked-daapd/patches/010-alsa.patch
@@ -0,0 +1,36 @@
+From 20f5118f7505e2e82be3504624ac934b8837d25b Mon Sep 17 00:00:00 2001
+From: Scott Shambarger <devel@shambarger.net>
+Date: Tue, 11 Jun 2019 20:10:04 -0700
+Subject: [PATCH] [alsa] asoundlib.h should be alsa/asoundlib.h
+
+---
+ configure.ac | 2 +-
+ src/outputs/alsa.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 9ec5eb101..98068bf11 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -238,7 +238,7 @@ AC_CHECK_SIZEOF([void *])
+ dnl --- Begin configuring the options ---
+ dnl ALSA
+ FORK_ARG_WITH_CHECK([FORKED_OPTS], [ALSA support], [alsa], [ALSA],
+- [alsa], [snd_mixer_open], [asoundlib.h])
++ [alsa], [snd_mixer_open], [alsa/asoundlib.h])
+ AM_CONDITIONAL([COND_ALSA], [[test "x$with_alsa" = "xyes"]])
+
+ dnl PULSEAUDIO
+diff --git a/src/outputs/alsa.c b/src/outputs/alsa.c
+index b696f0c3d..1a32aad19 100644
+--- a/src/outputs/alsa.c
++++ b/src/outputs/alsa.c
+@@ -30,7 +30,7 @@
+ #include <inttypes.h>
+
+ #include <event2/event.h>
+-#include <asoundlib.h>
++#include <alsa/asoundlib.h>
+
+ #include "misc.h"
+ #include "conffile.h"