aboutsummaryrefslogtreecommitdiff
path: root/sound/forked-daapd
diff options
context:
space:
mode:
authorejurgensen <espenjurgensen@gmail.com>2016-05-06 20:06:09 +0200
committerejurgensen <espenjurgensen@gmail.com>2016-05-06 20:06:09 +0200
commit385006f65c3caee78951ef477114cdbd917d18d0 (patch)
treeb9e1902b13e54d81a918e52c594e533ce42fcfa2 /sound/forked-daapd
parent44e86d440edcfba6bfe0c9c91157da73b2380a88 (diff)
forked-daapd: Update to version 24.1
Signed-off-by: Espen Jürgensen <espenjurgensen+openwrt@gmail.com>
Diffstat (limited to 'sound/forked-daapd')
-rw-r--r--sound/forked-daapd/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/sound/forked-daapd/Makefile b/sound/forked-daapd/Makefile
index 9388c6e46..7f2c7225d 100644
--- a/sound/forked-daapd/Makefile
+++ b/sound/forked-daapd/Makefile
@@ -8,9 +8,9 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=forked-daapd
-PKG_VERSION:=23.4
-PKG_RELEASE:=20160101
-PKG_REV:=90514de7c8d9bf06b54596bc66e0668181eee25a
+PKG_VERSION:=24.1
+PKG_RELEASE:=1
+PKG_REV:=524d060b7a9a68ab4375460d2da611a80e4fc18b
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
@@ -37,14 +37,15 @@ TITLE:=iTunes (DAAP) server for Apple Remote and AirPlay
URL:=https://github.com/ejurgensen/forked-daapd
DEPENDS:=+libgpg-error +libgcrypt +libgdbm +zlib +libexpat +libunistring \
+libevent2 +libdaemon +libantlr3c +confuse +alsa-lib +libffmpeg-full \
- +mxml +libavahi-client +sqlite3-cli +libplist +libcurl $(ICONV_DEPENDS)
+ +mxml +libavahi-client +sqlite3-cli +libplist +libcurl +libjson-c \
+ +libprotobuf-c +libgnutls $(ICONV_DEPENDS)
endef
define Package/forked-daapd/description
forked-daapd is a Linux/FreeBSD DAAP (iTunes), MPD (Music Player Daemon) and
- RSP (Roku) media server. It has support for AirPlay devices/speakers, Apple
- Remote (and compatibles), MPD clients, internet radio and LastFM. It does not
- support AirPlay video.
+ RSP (Roku) media server. It has support for AirPlay speakers, Chromecast,
+ Apple Remote (and compatibles), MPD clients, internet radio and LastFM. It
+ does not support AirPlay/Chromecast video.
endef
define Package/forked-daapd/conffiles
@@ -54,7 +55,8 @@ endef
CONFIGURE_ARGS += \
--enable-itunes \
--enable-lastfm \
- --enable-mpd
+ --enable-mpd \
+ --enable-chromecast
TARGET_CFLAGS += $(FPIC)
TARGET_LDFLAGS += -Wl,-rpath-link,$(STAGING_DIR)/usr/lib