aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2018-10-03 13:20:30 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2018-10-07 14:40:52 +0300
commitffa10121311d1dbeea6d7644df10a35ca903ffb6 (patch)
treee552a24b8eb65d57f80495f11f65e76b47723894 /net
parent172ae80bc174fe032aa0336aedfe96e155eab76c (diff)
keepalived: disable libnl
When libnl is enabled and libnl-genl is disabled, libnl-genl-3.so.200 is installed by InstallDev, and keepalived picks it up anyway. This causes build to fail with the following error: Package keepalived is missing dependencies for the following libraries: libnl-genl-3.so.200 Instead of having a conditional dependency it is better to have a consistent build. Disable libnl to enforce this. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'net')
-rw-r--r--net/keepalived/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net/keepalived/Makefile b/net/keepalived/Makefile
index 10ef3f899..dfbed1b41 100644
--- a/net/keepalived/Makefile
+++ b/net/keepalived/Makefile
@@ -31,7 +31,6 @@ define Package/keepalived
TITLE:=Failover and monitoring daemon for LVS clusters
URL:=http://www.keepalived.org/
DEPENDS:= \
- +PACKAGE_libnl-genl:libnl-genl \
+libopenssl \
+libip4tc \
+IPV6:libip6tc \
@@ -54,6 +53,7 @@ define Package/keepalived/conffiles
endef
CONFIGURE_ARGS+= \
+ --disable-libnl \
--enable-sha1 \
--disable-snmp \
--with-kernel-dir="$(LINUX_DIR)/$(LINUX_UAPI_DIR)"