aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2014-09-17 23:56:49 +0300
committerAlexandru Ardelean <ardeleanalex@gmail.com>2014-09-17 23:56:49 +0300
commitff1dd56ee050182a1d60cc56dc685848e0209857 (patch)
treedc40e1bcb61444489421029e7d65b960350bf6d7 /net
parente8aaebb2df9fcc5e91b63727f88f3a3faac70313 (diff)
openvswitch: remove ovs-controller package
According to the NEWS message from the main OVS site: http://openvswitch.org/releases/NEWS-2.3.0 Excerpt: - ovs-controller has been renamed test-controller. It is no longer packaged or installed by default, because too many users assumed incorrectly that ovs-controller was a necessary or desirable part of an Open vSwitch deployment. Current feed was updated based on a feed that packaged OVS 1.9, and subsequently updated. For now, we'll remove it, since it's not required. When I tested the feed, I tested it on a setup that has been configured some time ago, and does not have that package enabled. So, I'll remove it to prevent confusion. Signed-off-by: Alexandru Ardelean ardeleanalex@gmail.com
Diffstat (limited to 'net')
-rw-r--r--net/openvswitch/Makefile20
1 files changed, 1 insertions, 19 deletions
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index 8935b01c4..1ac882632 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -53,8 +53,7 @@ define Package/openvswitch-common
endef
define Package/openvswitch-common/description
- openvswitch-common provides components required by both openvswitch-switch and
- openvswitch-controller.
+ openvswitch-common provides components required by openvswitch-switch.
endef
define Package/openvswitch-ipsec
@@ -78,17 +77,6 @@ define Package/openvswitch-benchmark/description
Utility for running OpenVSwitch benchmarking
endef
-define Package/openvswitch-controller
- $(call Package/openvswitch/Default)
- TITLE:=Open vSwitch Userspace Package
- DEPENDS:=+openvswitch-common
-endef
-
-define Package/openvswitch-controller/description
- The Open vSwitch controller enables OpenFlow switches that connect to it to
- act as MAC-learning Ethernet switches.
-endef
-
define Package/openvswitch-switch
$(call Package/openvswitch/Default)
TITLE:=Open vSwitch Userspace Package
@@ -179,11 +167,6 @@ define Package/openvswitch-common/postinst
[ -n "$${IPKG_INSTROOT}" ] || /etc/init.d/openvswitch enable || true
endef
-define Package/openvswitch-controller/install
- $(INSTALL_DIR) $(1)/usr/bin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/utilities/.libs/ovs-controller $(1)/usr/bin/
-endef
-
define Package/openvswitch-switch/install
$(INSTALL_DIR) $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/utilities/.libs/ovs-dpctl $(1)/usr/bin/
@@ -200,7 +183,6 @@ endef
$(eval $(call BuildPackage,openvswitch-ipsec))
$(eval $(call BuildPackage,openvswitch-common))
-$(eval $(call BuildPackage,openvswitch-controller))
$(eval $(call BuildPackage,openvswitch-switch))
$(eval $(call BuildPackage,openvswitch-benchmark))
$(eval $(call KernelPackage,openvswitch))