aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2022-12-08 00:02:18 +0200
committerGitHub <noreply@github.com>2022-12-08 00:02:18 +0200
commitfbe0e832e1713fe99723aace9d417cf62444db9c (patch)
tree290b629ff52b82d3d33584b5417990f18fb76f67 /net
parentd6b712cde6c3094562e143df69a8cd600af52be1 (diff)
parent1136e0ac3ca4eacd2de0ca51db0a2e652e0f8cce (diff)
Merge pull request #19933 from stintel/vallumd
vallumd: updates
Diffstat (limited to 'net')
-rw-r--r--net/vallumd/Makefile7
-rw-r--r--net/vallumd/patches/001-CMake-skip-git-magic-if-no-.git-dir-exists.patch78
2 files changed, 82 insertions, 3 deletions
diff --git a/net/vallumd/Makefile b/net/vallumd/Makefile
index 5edc128a5..75b2470da 100644
--- a/net/vallumd/Makefile
+++ b/net/vallumd/Makefile
@@ -8,12 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=vallumd
-PKG_VERSION:=0.2.0
+PKG_VERSION:=0.2.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://codeload.github.com/stintel/vallumd/tar.gz/$(PKG_VERSION)?
-PKG_HASH:=7c1baffa3f7889c9c6f2795aac134c50a309ef201764d5ce6bbbce5d657416c0
+PKG_SOURCE_URL:=https://codeberg.org/stintel/vallumd/archive/$(PKG_VERSION).tar.gz?
+PKG_HASH:=f88cafce41cc118862869268b5e6c9b315a6f084aa8a498d4484e9dac49c575c
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
PKG_MAINTAINER:=Stijn Tintel <stijn@linux-ipv6.be>
PKG_LICENSE:=GPL-3.0
diff --git a/net/vallumd/patches/001-CMake-skip-git-magic-if-no-.git-dir-exists.patch b/net/vallumd/patches/001-CMake-skip-git-magic-if-no-.git-dir-exists.patch
new file mode 100644
index 000000000..82a659dfb
--- /dev/null
+++ b/net/vallumd/patches/001-CMake-skip-git-magic-if-no-.git-dir-exists.patch
@@ -0,0 +1,78 @@
+From b70137d0cc62be7f43816a3ba33b7c3e6a2fbd4e Mon Sep 17 00:00:00 2001
+From: Stijn Tintel <stijn@linux-ipv6.be>
+Date: Fri, 18 Nov 2022 09:19:02 +0200
+Subject: [PATCH] CMake: skip git magic if no .git dir exists
+
+The checks to fail CMake if git describe isn't working break build when
+building from source tarballs.
+
+Test if there is a git directory, and completely skip the git magic if
+not.
+
+Fixes: f42e7beec46e ("CI: add explicit clone to fetch tags")
+Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
+---
+ CMakeLists.txt | 51 +++++++++++++++++++++++++-------------------------
+ 1 file changed, 26 insertions(+), 25 deletions(-)
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -9,35 +9,36 @@ set (VERSION_MAJOR 0)
+ set (VERSION_MINOR 2)
+ set (VERSION_PATCH 2)
+
+-execute_process(COMMAND git describe --tags --dirty
+- OUTPUT_VARIABLE GIT_DESCRIBE
+- OUTPUT_STRIP_TRAILING_WHITESPACE ERROR_QUIET)
+-execute_process(COMMAND git describe --abbrev=0
+- OUTPUT_VARIABLE GIT_LAST_TAG
+- OUTPUT_STRIP_TRAILING_WHITESPACE ERROR_QUIET)
++if (EXISTS .git/)
++ execute_process(COMMAND git describe --tags --dirty
++ OUTPUT_VARIABLE GIT_DESCRIBE
++ OUTPUT_STRIP_TRAILING_WHITESPACE ERROR_QUIET)
++ execute_process(COMMAND git describe --abbrev=0
++ OUTPUT_VARIABLE GIT_LAST_TAG
++ OUTPUT_STRIP_TRAILING_WHITESPACE ERROR_QUIET)
+
+-string(LENGTH "${GIT_DESCRIBE}" GIT_DESCRIBE_LEN)
+-string(LENGTH "${GIT_LAST_TAG}" GIT_LAST_TAG_LEN)
++ string(LENGTH "${GIT_DESCRIBE}" GIT_DESCRIBE_LEN)
++ string(LENGTH "${GIT_LAST_TAG}" GIT_LAST_TAG_LEN)
+
+-if (GIT_DESCRIBE_LEN EQUAL 0 OR GIT_LAST_TAG_LEN EQUAL 0)
+- message(FATAL_ERROR "git describe output empty")
+-endif ()
++ if (GIT_DESCRIBE_LEN EQUAL 0 OR GIT_LAST_TAG_LEN EQUAL 0)
++ message(FATAL_ERROR "git describe output empty")
++ endif ()
+
+-string(REGEX REPLACE "^${GIT_LAST_TAG}-" "" GIT_DESCRIBE_NOTAG "${GIT_DESCRIBE}")
++ string(REGEX REPLACE "^${GIT_LAST_TAG}-" "" GIT_DESCRIBE_NOTAG "${GIT_DESCRIBE}")
+
+-if (NOT "${GIT_DESCRIBE}" STREQUAL "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}")
+- if ("${GIT_LAST_TAG}" VERSION_LESS
+- "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}")
+- string(REGEX REPLACE "^${GIT_LAST_TAG}-"
+- "" VERSION_TWEAK "0-pre-${GIT_DESCRIBE_NOTAG}")
+- else ()
+- string(REGEX REPLACE
+- "^${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}-"
+- "" VERSION_TWEAK "${GIT_DESCRIBE}")
++ if (NOT "${GIT_DESCRIBE}" STREQUAL "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}")
++ if ("${GIT_LAST_TAG}" VERSION_LESS
++ "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}")
++ string(REGEX REPLACE "^${GIT_LAST_TAG}-"
++ "" VERSION_TWEAK "0-pre-${GIT_DESCRIBE_NOTAG}")
++ else ()
++ string(REGEX REPLACE
++ "^${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}-"
++ "" VERSION_TWEAK "${GIT_DESCRIBE}")
++ endif ()
+ endif ()
+ endif ()
+
+-
+ configure_file (
+ "${PROJECT_SOURCE_DIR}/src/config.h.in"
+ "${PROJECT_BINARY_DIR}/config.h"