aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRichard Yu <yurichard3839@gmail.com>2019-10-12 10:32:04 +0800
committerRichard Yu <yurichard3839@gmail.com>2019-10-12 10:32:04 +0800
commitf6ee8cb4e28846b94fd02f169197b5f6a3fe451d (patch)
tree86f6d9bbd63765a441f01c4148f0bbdd4fa39122 /net
parent679f10bdc7c96673df3e74e844110b183ce477c1 (diff)
cifsd: update to git (2019-10-08)
Signed-off-by: Richard Yu <yurichard3839@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/cifsd-tools/Makefile10
-rw-r--r--net/cifsd-tools/files/smb.conf.help5
2 files changed, 10 insertions, 5 deletions
diff --git a/net/cifsd-tools/Makefile b/net/cifsd-tools/Makefile
index 591b1ee7f..c13af0c8c 100644
--- a/net/cifsd-tools/Makefile
+++ b/net/cifsd-tools/Makefile
@@ -5,9 +5,9 @@ PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/cifsd-team/cifsd-tools.git
-PKG_SOURCE_DATE:=2019-08-19
-PKG_SOURCE_VERSION:=bbeab27f0a1695f711fb84d9cd29a83f818ef90e
-PKG_MIRROR_HASH:=f8bef545400aa8c0db6ba0fffdf0c0a2f201603503728f140df133aff3a39cbb
+PKG_SOURCE_DATE:=2019-10-08
+PKG_SOURCE_VERSION:=4bc2d762eb32577b30a14b6991cd10026d99eb05
+PKG_MIRROR_HASH:=87edfb18bcf7c3c8558dc649b91a470aba0cee781e448b2f56ef7d774b6b40d3
PKG_MAINTAINER:=Andy Walsh <andy.walsh44+github@gmail.com>
PKG_LICENSE:=GPL-2.0-or-later
@@ -31,7 +31,7 @@ define Package/cifsd-tools
endef
define Package/cifsd-tools/description
- Userspace tools (cifsd, cifsadmin) for the CIFS/SMB kernel fileserver.
+ Userspace tools (cifsd, cifsuseradd, cifsshareadd) for the CIFS/SMB kernel fileserver.
The config file location is /etc/cifs/smb.conf
endef
@@ -39,7 +39,7 @@ define Package/cifsd-tools/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libcifsdtools.so* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{cifsadmin,cifsd} $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{cifsuseradd,cifsshareadd,cifsd} $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/config $(1)/etc/cifs $(1)/etc/init.d
$(INSTALL_CONF) ./files/cifsd.config $(1)/etc/config/cifsd
$(INSTALL_DATA) ./files/smb.conf.template $(1)/etc/cifs/
diff --git a/net/cifsd-tools/files/smb.conf.help b/net/cifsd-tools/files/smb.conf.help
index a4c29d268..23d0c8d37 100644
--- a/net/cifsd-tools/files/smb.conf.help
+++ b/net/cifsd-tools/files/smb.conf.help
@@ -54,6 +54,11 @@
; the number of minutes of inactivity before a connection is
; considered dead, and it is disconnected. The deadtime only
; takes effect if the number of open files is zero.
+; - root directory
+; Sets up a root (base) directory for all shares. In some
+; sense it's equal to chroot(). When this option set all shares'
+; paths become relative to root directory, IOW the file name
+; lookup resolves '/root directory/share path/file path' path.
;
; Supported [share] level parameters list:
; - comment