aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-03-31 13:57:08 -0700
committerRosen Penev <rosenp@gmail.com>2019-04-01 12:29:17 -0700
commitf6aeed318705aa2921a593f409ff8e3c0a5f1381 (patch)
treec3a5ed5d09f4ba1961d134764c5dce21d3dd054c /net
parentbd5adb68ed5e66e5edfe0db97d1cdf6c33099b62 (diff)
unbound: Make ECDSA support explicit
Added a dependency to OPENSSL_WITH_EC to prevent any build failures. Switched URLs to HTTPS. Added PKG_CPE_ID for proper CVE tracking. Some Makefile reorganization for consistency between packages. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/unbound/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/net/unbound/Makefile b/net/unbound/Makefile
index 030c5ff1e..bd196708a 100644
--- a/net/unbound/Makefile
+++ b/net/unbound/Makefile
@@ -9,16 +9,17 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=unbound
PKG_VERSION:=1.9.1
-PKG_RELEASE:=1
-
-PKG_LICENSE:=BSD-3-Clause
-PKG_LICENSE_FILES:=LICENSE
-PKG_MAINTAINER:=Eric Luehrsen <ericluehrsen@gmail.com>
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.unbound.net/downloads
+PKG_SOURCE_URL:=https://www.unbound.net/downloads
PKG_HASH:=c3c0bf9b86ccba4ca64f93dd4fe7351308ab54293f297a67de5a8914c1dc59c5
+PKG_MAINTAINER:=Eric Luehrsen <ericluehrsen@gmail.com>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+PKG_CPE_ID:=cpe:/a:nlnetlabs:unbound
+
PKG_BUILD_PARALLEL:=1
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
@@ -27,8 +28,8 @@ include $(INCLUDE_DIR)/package.mk
define Package/unbound/Default
TITLE:=Validating Recursive DNS Server
- URL:=http://www.unbound.net/
- DEPENDS:=+libopenssl
+ URL:=https://www.unbound.net/
+ DEPENDS:=+libopenssl @OPENSSL_WITH_EC
endef
define Package/unbound
@@ -113,6 +114,7 @@ CONFIGURE_ARGS += \
--disable-dsa \
--disable-gost \
--enable-allsymbols \
+ --enable-ecdsa \
--enable-tfo-client \
--enable-tfo-server \
--with-libexpat="$(STAGING_DIR)/usr" \