aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-04-07 15:43:07 -0700
committerRosen Penev <rosenp@gmail.com>2019-04-07 15:49:43 -0700
commitf478209bce71ad6b6f24cdaad4e9b8ac1244094c (patch)
tree53ed87bcc919dcf7937ba64a7c441c9fc6d2d6ec /net
parent41e005c7b4e161348467767b89851afe85f1ae0f (diff)
kea: Specify OpenSSL location
Some buildbots are failing on this. Refreshed patches. Replace -fPIC with $(FPIC) Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/kea/Makefile7
-rw-r--r--net/kea/patches/001-fix-cross-compile.patch2
2 files changed, 6 insertions, 3 deletions
diff --git a/net/kea/Makefile b/net/kea/Makefile
index e66aedd62..36c035db9 100644
--- a/net/kea/Makefile
+++ b/net/kea/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=kea
PKG_VERSION:=1.5.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=BangLang Huang<banglang.huang@foxmail.com>, Rosy Song<rosysong@rosinson.com>
PKG_BUILD_DEPENDS:=boost log4cplus kea/host
HOST_BUILD_DEPENDS:=boost boost/host log4cplus/host
@@ -99,6 +99,7 @@ endef
CONFIGURE_ARGS += \
--with-log4cplus="$(STAGING_DIR)/usr" \
+ --with-openssl="$(STAGING_DIR)/usr" \
$(if $(CONFIG_PACKAGE_kea-perfdhcp),--enable-perfdhcp,)
CONFIGURE_VARS += \
@@ -108,12 +109,14 @@ HOST_CONFIGURE_ARGS += \
--enable-static-link \
--enable-boost-headers-only \
--with-log4cplus="$(STAGING_DIR_HOSTPKG)" \
- --with-boost-include="$(STAGING_DIR)/usr/include"
+ --with-boost-include="$(STAGING_DIR)/usr/include" \
+ --without-pic
HOST_LDFLAGS += \
-Wl,--gc-sections,--as-needed
TARGET_CXXFLAGS += \
+ $(FPIC) \
-fdata-sections \
-ffunction-sections
diff --git a/net/kea/patches/001-fix-cross-compile.patch b/net/kea/patches/001-fix-cross-compile.patch
index 40a47501a..d3a1521a9 100644
--- a/net/kea/patches/001-fix-cross-compile.patch
+++ b/net/kea/patches/001-fix-cross-compile.patch
@@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -594,10 +594,10 @@ AC_TRY_COMPILE([
+@@ -580,10 +580,10 @@ AC_TRY_COMPILE([
AC_MSG_RESULT(no))
AC_MSG_CHECKING(for usuable C++11 regex)