aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2015-10-30 15:42:41 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2015-11-03 15:13:33 +0800
commitf335446e3b4df892387cd4480e1239f9be082759 (patch)
tree2da30e0f9cfd2a2f9f0439e0fbbb22daa313b46c /net
parent8b18ca42f07c2a6ca90c7f12e8aff58048ca6d53 (diff)
pppossh: use exec with pty option to eliminate a level of bufferbloat
While at it, also do the following fixes - Drop the URL pointing to the old github repo - Fix detection of default set of private keys Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/pppossh/Makefile3
-rw-r--r--net/pppossh/files/pppossh.sh4
2 files changed, 3 insertions, 4 deletions
diff --git a/net/pppossh/Makefile b/net/pppossh/Makefile
index 5dc74e230..a4a048fcc 100644
--- a/net/pppossh/Makefile
+++ b/net/pppossh/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=pppossh
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
PKG_LICENSE:=GPLv2
@@ -18,7 +18,6 @@ define Package/pppossh
SECTION:=net
CATEGORY:=Network
TITLE:=PPPoSSH (Point-to-Point Protocol over SSH)
- URL:=https://github.com/yousong/waller
DEPENDS:=+ppp +resolveip @(PACKAGE_dropbear||PACKAGE_openssh-client)
endef
diff --git a/net/pppossh/files/pppossh.sh b/net/pppossh/files/pppossh.sh
index f50ec84f2..421980d09 100644
--- a/net/pppossh/files/pppossh.sh
+++ b/net/pppossh/files/pppossh.sh
@@ -46,7 +46,7 @@ proto_pppossh_setup() {
[ -n "$sshuser" ] || errmsg="${errmsg}Missing sshuser option\n"
json_get_values identity identity
- [ -z "$identity" ] && identity="'$home/.ssh/id_rsa' '$home/.ssh/id_dsa'"
+ [ -z "$identity" ] && identity="$home/.ssh/id_rsa $home/.ssh/id_dsa"
for fn in $identity; do
[ -f "$fn" ] && opts="$opts -i $fn"
done
@@ -60,7 +60,7 @@ proto_pppossh_setup() {
opts="$opts ${port:+-p $port}"
opts="$opts ${ssh_options}"
opts="$opts $sshuser@$server"
- pty="env 'HOME=$home' "$SSH" $opts pppd nodetach notty noauth"
+ pty="exec env 'HOME=$home' $SSH $opts pppd nodetach notty noauth"
ppp_generic_setup "$config" noauth pty "$pty" "$ipaddr:$peeraddr"
}